aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/mx6qsabrelite-fix-console.patch26
-rw-r--r--recipes-bsp/u-boot/u-boot/mx53-fix-uart-clock.patch55
-rw-r--r--recipes-bsp/u-boot/u-boot/mx6qsabrelite_add_CONFIG_REVISION_TAG.patch48
-rw-r--r--recipes-bsp/u-boot/u-boot/mx6qsabrelite_add_MACH_TYPE_MX6Q_SABRELITE.patch25
-rw-r--r--recipes-bsp/u-boot/u-boot_2012.04.bb (renamed from recipes-bsp/u-boot/u-boot_git.bb)13
5 files changed, 3 insertions, 164 deletions
diff --git a/recipes-bsp/u-boot/mx6qsabrelite-fix-console.patch b/recipes-bsp/u-boot/mx6qsabrelite-fix-console.patch
deleted file mode 100644
index 4bbb490..0000000
--- a/recipes-bsp/u-boot/mx6qsabrelite-fix-console.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Date: Wed, 28 Mar 2012 16:42:27 -0300
-Subject: [PATCH] mx6qsabrelite: Fix the serial console port
-
-On mx6qsabrelite the console is ttymxc1.
-
-Signed-off-by: Fabio Estevam <fabio.estevam@freescale.com>
----
- include/configs/mx6qsabrelite.h | 2 +-
- 1 files changed, 1 insertions(+), 1 deletions(-)
-
-diff --git a/include/configs/mx6qsabrelite.h b/include/configs/mx6qsabrelite.h
-index 8bc8a83..2643817 100644
---- a/include/configs/mx6qsabrelite.h
-+++ b/include/configs/mx6qsabrelite.h
-@@ -116,7 +116,7 @@
- #define CONFIG_EXTRA_ENV_SETTINGS \
- "script=boot.scr\0" \
- "uimage=uImage\0" \
-- "console=ttymxc3\0" \
-+ "console=ttymxc1\0" \
- "fdt_high=0xffffffff\0" \
- "initrd_high=0xffffffff\0" \
- "mmcdev=0\0" \
---
-1.7.1
-
diff --git a/recipes-bsp/u-boot/u-boot/mx53-fix-uart-clock.patch b/recipes-bsp/u-boot/u-boot/mx53-fix-uart-clock.patch
deleted file mode 100644
index 7d4f6bc..0000000
--- a/recipes-bsp/u-boot/u-boot/mx53-fix-uart-clock.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-Change the parent UART clock to be PLL2, so that U-boot can also boot
-a Freescale 2.6.35 kernel for mx53.
-
-FSL kernel and U-boot changed the UART parent from PLL3 to PLL2 to avoid
-conflicts with IPU clocks, so that the video resolution can be changed
-without affecting the UART clock.
-
-On a 2.6.35 kernel the serial console is messed up after IPU driver is loaded
-and this patch fixes this problem.
-
-Tested on a mx53loco board booting a FSL kernel and also a mainline kernel.
-
-Upstream-Status: Submitted [under review]
-
-Reported-by: Otavio Salvador <otavio@ossystems.com.br>
-Signed-off-by: Fabio Estevam <fabio.estevam@freescale.com>
----
- arch/arm/cpu/armv7/mx5/lowlevel_init.S | 20 +++++++++++++++++---
- 1 files changed, 17 insertions(+), 3 deletions(-)
-
-diff --git a/arch/arm/cpu/armv7/mx5/lowlevel_init.S b/arch/arm/cpu/armv7/mx5/lowlevel_init.S
-index 01f6d75..90c6ec1 100644
---- a/arch/arm/cpu/armv7/mx5/lowlevel_init.S
-+++ b/arch/arm/cpu/armv7/mx5/lowlevel_init.S
-@@ -284,10 +284,24 @@
- ldr r1, =0x00C30321
- str r1, [r0, #CLKCTL_CSCDR1]
- #elif defined(CONFIG_MX53)
-+ /* Switch peripheral to PLL2 */
-+ ldr r0, =CCM_BASE_ADDR
-+ ldr r1, =0x00808145
-+ orr r1, r1, #(2 << 10)
-+ orr r1, r1, #(0 << 16)
-+ orr r1, r1, #(1 << 19)
-+ str r1, [r0, #CLKCTL_CBCDR]
-+
-+ ldr r1, =0x00016154
-+ str r1, [r0, #CLKCTL_CBCMR]
-+ /* Change uart clk parent to pll2*/
-+ ldr r1, [r0, #CLKCTL_CSCMR1]
-+ and r1, r1, #0xfcffffff
-+ orr r1, r1, #0x01000000
-+ str r1, [r0, #CLKCTL_CSCMR1]
- ldr r1, [r0, #CLKCTL_CSCDR1]
-- orr r1, r1, #0x3f
-- eor r1, r1, #0x3f
-- orr r1, r1, #0x21
-+ and r1, r1, #0xffffffc0
-+ orr r1, r1, #0x0a
- str r1, [r0, #CLKCTL_CSCDR1]
- #endif
- /* make sure divider effective */
---
-1.7.1
-
diff --git a/recipes-bsp/u-boot/u-boot/mx6qsabrelite_add_CONFIG_REVISION_TAG.patch b/recipes-bsp/u-boot/u-boot/mx6qsabrelite_add_CONFIG_REVISION_TAG.patch
deleted file mode 100644
index f9614fe..0000000
--- a/recipes-bsp/u-boot/u-boot/mx6qsabrelite_add_CONFIG_REVISION_TAG.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-From: Eric Nelson <eric.nelson@boundarydevices.com>
-Date: Mon, 12 Mar 2012 15:04:12 +0000 (+0000)
-Subject: i.MX6: mx6q_sabrelite: add CONFIG_REVISION_TAG
-X-Git-Url: http://git.denx.de/?p=u-boot%2Fu-boot-imx.git;a=commitdiff_plain;h=044cd2a7318a6480346c4e0824956d0dd25e9ec3;hp=b0634306b222cca35ad4754091c718a59f912bc0
-
-i.MX6: mx6q_sabrelite: add CONFIG_REVISION_TAG
-
-This is needed to support Freescale-supplied userspaces.
-
-At the moment, both the IPU and VPU libraries provided by Freescale
-in the "imx-lib" package contain routines which scrape the system
-revision from /proc/cpuinfo. In the VPU library, this information is
-used to load the proper firmware, allowing a single binary to be used
-across various i.MX processors.
-
-Signed-off-by: Eric Nelson <eric.nelson@boundarydevices.com>
-Acked-by: Marek Vasut <marex@denx.de>
-Acked-by: Stefano Babic <sbabic@denx.de>
----
-
-diff --git a/board/freescale/mx6qsabrelite/mx6qsabrelite.c b/board/freescale/mx6qsabrelite/mx6qsabrelite.c
-index 7fe2dc9..1d09a72 100644
---- a/board/freescale/mx6qsabrelite/mx6qsabrelite.c
-+++ b/board/freescale/mx6qsabrelite/mx6qsabrelite.c
-@@ -215,6 +215,11 @@ int board_mmc_init(bd_t *bis)
- }
- #endif
-
-+u32 get_board_rev(void)
-+{
-+ return 0x63000 ;
-+}
-+
- #ifdef CONFIG_MXC_SPI
- iomux_v3_cfg_t ecspi1_pads[] = {
- /* SS1 */
-diff --git a/include/configs/mx6qsabrelite.h b/include/configs/mx6qsabrelite.h
-index bb3a46b..a1a2267 100644
---- a/include/configs/mx6qsabrelite.h
-+++ b/include/configs/mx6qsabrelite.h
-@@ -33,6 +33,7 @@
- #define CONFIG_CMDLINE_TAG
- #define CONFIG_SETUP_MEMORY_TAGS
- #define CONFIG_INITRD_TAG
-+#define CONFIG_REVISION_TAG
-
- /* Size of malloc() pool */
- #define CONFIG_SYS_MALLOC_LEN (CONFIG_ENV_SIZE + 2 * 1024 * 1024)
diff --git a/recipes-bsp/u-boot/u-boot/mx6qsabrelite_add_MACH_TYPE_MX6Q_SABRELITE.patch b/recipes-bsp/u-boot/u-boot/mx6qsabrelite_add_MACH_TYPE_MX6Q_SABRELITE.patch
deleted file mode 100644
index 09c74af..0000000
--- a/recipes-bsp/u-boot/u-boot/mx6qsabrelite_add_MACH_TYPE_MX6Q_SABRELITE.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-From: Eric Nelson <eric.nelson@boundarydevices.com>
-Date: Sun, 4 Mar 2012 10:51:36 +0000 (+0000)
-Subject: i.MX6: mx6qsabrelite: add MACH_TYPE_MX6Q_SABRELITE
-X-Git-Url: http://git.denx.de/?p=u-boot%2Fu-boot-imx.git;a=commitdiff_plain;h=5152d09fe89768a119b016b21fc763bc0231d1e8;hp=044cd2a7318a6480346c4e0824956d0dd25e9ec3
-
-i.MX6: mx6qsabrelite: add MACH_TYPE_MX6Q_SABRELITE
-
-Allow non-dt kernels to boot
-
-Signed-off-by: Troy Kisky <troy.kisky@boundarydevices.com>
----
-
-diff --git a/include/configs/mx6qsabrelite.h b/include/configs/mx6qsabrelite.h
-index a1a2267..8bc8a83 100644
---- a/include/configs/mx6qsabrelite.h
-+++ b/include/configs/mx6qsabrelite.h
-@@ -28,6 +28,8 @@
- #define CONFIG_DISPLAY_CPUINFO
- #define CONFIG_DISPLAY_BOARDINFO
-
-+#define CONFIG_MACH_TYPE 3769
-+
- #include <asm/arch/imx-regs.h>
-
- #define CONFIG_CMDLINE_TAG
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_2012.04.bb
index 7c1febf..4f24183 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_2012.04.bb
@@ -6,18 +6,11 @@ COMPATIBLE_MACHINE = "(imx53qsb|imx53ard|imx51evk|imx28evk|imx6qsabrelite)"
DEPENDS_mxs += "elftosb-native"
-PR = "r3"
+SRCREV = "2790bf69dc12fb9aeb9836904e5f57c7f83d5552"
-SRCREV = "6751b05f855bbe56005d5b88d4eb58bcd52170d2"
+PV = "v2012.04"
-PV = "v2011.12+git"
-
-SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git \
- file://mx53-fix-uart-clock.patch \
- file://mx6qsabrelite_add_CONFIG_REVISION_TAG.patch \
- file://mx6qsabrelite_add_MACH_TYPE_MX6Q_SABRELITE.patch \
- file://mx6qsabrelite-fix-console.patch \
- "
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
S = "${WORKDIR}/git"