aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot_2012.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot_2012.07.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot_2012.07.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_2012.07.bb b/recipes-bsp/u-boot/u-boot_2012.07.bb
new file mode 100644
index 0000000..d3f3abc
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_2012.07.bb
@@ -0,0 +1,23 @@
+require recipes-bsp/u-boot/u-boot.inc
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
+COMPATIBLE_MACHINE = "(imx28evk|mx5|mx6)"
+
+DEPENDS_mxs += "elftosb-native"
+
+SRCREV = "573e018c01178616ecf04e088e1a5b99537db694"
+
+PV = "v2012.07"
+
+SRC_URI = "git://github.com/Freescale/u-boot-imx.git"
+
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_compile_prepend() {
+ if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
+ sed -i 's/$(CROSS_COMPILE)ld/$(CROSS_COMPILE)ld.bfd/g' config.mk
+ fi
+}