aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot_2012.04.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot_2012.04.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot_2012.04.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot_2012.04.bb b/recipes-bsp/u-boot/u-boot_2012.04.bb
new file mode 100644
index 0000000..4f24183
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot_2012.04.bb
@@ -0,0 +1,23 @@
+require recipes-bsp/u-boot/u-boot.inc
+
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=1707d6db1d42237583f50183a5651ecb"
+COMPATIBLE_MACHINE = "(imx53qsb|imx53ard|imx51evk|imx28evk|imx6qsabrelite)"
+
+DEPENDS_mxs += "elftosb-native"
+
+SRCREV = "2790bf69dc12fb9aeb9836904e5f57c7f83d5552"
+
+PV = "v2012.04"
+
+SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
+
+S = "${WORKDIR}/git"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+do_compile_prepend() {
+ if [ "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', 'ld-is-gold', '', d)}" = "ld-is-gold" ] ; then
+ sed -i 's/$(CROSS_COMPILE)ld/$(CROSS_COMPILE)ld.bfd/g' config.mk
+ fi
+}