aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-v2012.04.01/0034-imx-Add-u-boot.imx-as-target-for-ARM9-i.MX-SOCs.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-v2012.04.01/0034-imx-Add-u-boot.imx-as-target-for-ARM9-i.MX-SOCs.patch')
-rw-r--r--recipes-bsp/u-boot/u-boot-v2012.04.01/0034-imx-Add-u-boot.imx-as-target-for-ARM9-i.MX-SOCs.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-v2012.04.01/0034-imx-Add-u-boot.imx-as-target-for-ARM9-i.MX-SOCs.patch b/recipes-bsp/u-boot/u-boot-v2012.04.01/0034-imx-Add-u-boot.imx-as-target-for-ARM9-i.MX-SOCs.patch
new file mode 100644
index 0000000..692d16a
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-v2012.04.01/0034-imx-Add-u-boot.imx-as-target-for-ARM9-i.MX-SOCs.patch
@@ -0,0 +1,28 @@
+From b2f6a61134714190757c7aa81c3ed935cff106fa Mon Sep 17 00:00:00 2001
+From: Timo Ketola <timo@exertus.fi>
+Date: Wed, 18 Apr 2012 22:55:35 +0000
+Subject: [PATCH 34/56] imx: Add u-boot.imx as target for ARM9 i.MX SOCs
+
+Signed-off-by: Timo Ketola <timo@exertus.fi>
+Acked-by: Stefano Babic <sbabic@denx.de>
+---
+ arch/arm/cpu/arm926ejs/config.mk | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/arch/arm/cpu/arm926ejs/config.mk b/arch/arm/cpu/arm926ejs/config.mk
+index ffb2e6c..6a3a1bb 100644
+--- a/arch/arm/cpu/arm926ejs/config.mk
++++ b/arch/arm/cpu/arm926ejs/config.mk
+@@ -31,3 +31,9 @@ PLATFORM_CPPFLAGS += -march=armv5te
+ # =========================================================================
+ PF_RELFLAGS_SLB_AT := $(call cc-option,-mshort-load-bytes,$(call cc-option,-malignment-traps,))
+ PLATFORM_RELFLAGS += $(PF_RELFLAGS_SLB_AT)
++
++ifneq ($(CONFIG_IMX_CONFIG),)
++
++ALL-y += $(obj)u-boot.imx
++
++endif
+--
+1.7.10
+