aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-ls1_2014.07.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-ls1_2014.07.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb b/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
new file mode 100644
index 0000000..96944c1
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-ls1_2014.07.bb
@@ -0,0 +1,24 @@
+require recipes-bsp/u-boot/u-boot.inc
+require u-boot-ls1.inc
+inherit fsl-u-boot-localversion
+
+LOCALVERSION ?= "-${SRCBRANCH}"
+
+DEPENDS += "u-boot-ls1-tools-native"
+PROVIDES += "u-boot"
+
+do_compile_append () {
+ case "${UBOOT_MACHINE}" in
+ *spi*) tclsh byte_swap.tcl ${S}/u-boot.bin ${S}/u-boot.swap.bin 8
+ mv ${S}/u-boot.swap.bin ${S}/u-boot.bin;;
+ esac
+}
+
+PACKAGES += "${PN}-images"
+FILES_${PN}-images += "/boot"
+
+ALLOW_EMPTY_${PN} = "1"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "(ls102xa)"
+