aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.07.bb')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.07.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.07.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.07.bb
new file mode 100644
index 0000000..920a84d
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2016.07.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "U-boot bootloader mxsboot tool"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
+SECTION = "bootloader"
+DEPENDS = "openssl"
+PROVIDES = "u-boot-mxsboot"
+
+PV = "v2016.07+git${SRCPV}"
+
+SRCREV = "f94327f2c92d88db8baabd45c61187c9c587673d"
+SRCBRANCH = "2016.07+fslc"
+
+SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
+
+S = "${WORKDIR}/git"
+
+inherit fsl-u-boot-localversion
+
+EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y'
+
+do_configure () {
+ oe_runmake sandbox_defconfig
+}
+
+do_compile () {
+ oe_runmake tools-only
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
+ ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
+}
+
+BBCLASSEXTEND = "native nativesdk"