aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/imx-kobs
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/imx-kobs')
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs/fix-cal_nfc_geometry.patch31
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs/raw-mode.patch48
-rw-r--r--recipes-bsp/imx-kobs/imx-kobs_5.4.bb19
3 files changed, 0 insertions, 98 deletions
diff --git a/recipes-bsp/imx-kobs/imx-kobs/fix-cal_nfc_geometry.patch b/recipes-bsp/imx-kobs/imx-kobs/fix-cal_nfc_geometry.patch
deleted file mode 100644
index dddb49a..0000000
--- a/recipes-bsp/imx-kobs/imx-kobs/fix-cal_nfc_geometry.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-The Freescale downstream vendor kernel has a patch that exports the bch
-flash geometry via a debugfs file. This is not available in mainline linux
-kernels so the fallback method calculates the geometry based on known info
-from the mtd partition. A bug exists in this funcion where it fails to
-assume that block0 ECC is the same as the other blocks by default.
-
-Upstream-Status: Pending
-
---- a/src/mtd.c
-+++ b/src/mtd.c
-@@ -610,7 +610,7 @@ static int cal_nfc_geometry(struct mtd_d
- /* The two are fixed, please change them when the driver changes. */
- geo->metadata_size_in_bytes = 10;
- geo->gf_len = 13;
-- geo->ecc_chunkn_size_in_bytes = 512;
-+ geo->ecc_chunkn_size_in_bytes = geo->ecc_chunk0_size_in_bytes = 512;
-
- if (mtd->oobsize > geo->ecc_chunkn_size_in_bytes) {
- geo->gf_len = 14;
-@@ -700,8 +700,9 @@ int parse_nfc_geometry(struct mtd_data *
- unsigned int value;
-
- if (!plat_config_data->m_u32UseNfcGeo) {
-+ /* fsl kernel patch provides bch_geometry via debugfs */
- if (!(node = fopen(dbg_geometry_node_path, "r"))) {
-- fprintf(stderr, "Cannot open BCH geometry node: \"%s\"",
-+ fprintf(stderr, "Cannot open BCH geometry node: \"%s\"\n",
- dbg_geometry_node_path);
- return cal_nfc_geometry(md);
- }
-
diff --git a/recipes-bsp/imx-kobs/imx-kobs/raw-mode.patch b/recipes-bsp/imx-kobs/imx-kobs/raw-mode.patch
deleted file mode 100644
index 76c2440..0000000
--- a/recipes-bsp/imx-kobs/imx-kobs/raw-mode.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-The downstream Freescale vendor kernel has a patch that allows determining
-if raw NAND flash mode is provided via a debugfs file. This is not present
-in upstream kernels, but the raw access support was added in the 3.19
-kernel, so we will check the kernel version if we can't find the file.
-
-Upstream-Status: Pending
-
---- a/src/mtd.c
-+++ b/src/mtd.c
-@@ -34,6 +34,7 @@
- #include <errno.h>
- #include <sys/types.h>
- #include <sys/ioctl.h>
-+#include <sys/utsname.h>
-
- #include "mtd.h"
- #include "rand.h"
-@@ -808,15 +809,27 @@ struct mtd_data *mtd_open(const struct m
- md->cfg = *cfg;
-
- /* check if use new raw access mode */
-+ /* by looking for debugfs from fsl patch */
-+ md->raw_mode_flag = 0;
- fp = fopen("/sys/kernel/debug/gpmi-nand/raw_mode", "r");
- if (!fp) {
-- md->raw_mode_flag = 0;
-- vp(md, "mtd: use legacy raw access mode\n");
-+ /* fallback to kernel version: raw access added in 3.19 */
-+ struct utsname uts;
-+ if (!uname(&uts)) {
-+ int major = 0, minor = 0;
-+ sscanf(uts.release, "%d.%d", &major, &minor);
-+ vp(md, "mtd: Linux %d.%d\n", major, minor);
-+ if ((major << 8 | minor) > (3 << 8 | 18))
-+ md->raw_mode_flag = 1;
-+ }
- } else {
- fclose(fp);
- md->raw_mode_flag = 1;
-- vp(md, "mtd: use new bch layout raw access mode\n");
- }
-+ if (md->raw_mode_flag)
-+ vp(md, "mtd: use new bch layout raw access mode\n");
-+ else
-+ vp(md, "mtd: use legacy raw access mode\n");
-
- if (plat_config_data->m_u32UseMultiBootArea) {
-
diff --git a/recipes-bsp/imx-kobs/imx-kobs_5.4.bb b/recipes-bsp/imx-kobs/imx-kobs_5.4.bb
deleted file mode 100644
index de396a1..0000000
--- a/recipes-bsp/imx-kobs/imx-kobs_5.4.bb
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright (C) 2013-2016 Freescale Semiconductor
-
-SUMMARY = "Nand boot write source"
-SECTION = "base"
-LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
-
-SRC_URI = "${FSL_MIRROR}/imx-kobs-${PV}.tar.gz \
- file://fix-compile.patch \
- file://raw-mode.patch \
- file://fix-cal_nfc_geometry.patch \
-"
-
-SRC_URI[md5sum] = "77467d834f858c2ec216841583e5f437"
-SRC_URI[sha256sum] = "85171b46068ac47c42fedb8104167bf9afd33dd9527ed127e1ca2eb29d7a86bf"
-
-inherit autotools pkgconfig
-
-COMPATIBLE_MACHINE = "(imx)"