aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp/apptrk/apptrk_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp/apptrk/apptrk_git.bb')
-rw-r--r--recipes-bsp/apptrk/apptrk_git.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes-bsp/apptrk/apptrk_git.bb b/recipes-bsp/apptrk/apptrk_git.bb
new file mode 100644
index 0000000..4453cf8
--- /dev/null
+++ b/recipes-bsp/apptrk/apptrk_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Debug agent for Freescale CodeWarrior"
+SECTION = "apptrk"
+LICENSE = "Freescale-EULA"
+LIC_FILES_CHKSUM = "file://COPYING;md5=95560debfde180684364319811cc1421"
+
+DEPENDS = "elfutils"
+
+inherit kernel-arch
+
+SRC_URI = "git://git.freescale.com/ppc/sdk/apptrk.git;nobranch=1 \
+ file://apptrk-install-create-all-components-of-DEST.patch \
+ file://no-strip.patch \
+"
+SRCREV = "cbed10997c5e2a4aaa004fb0e1efec858bf1bbe1"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = ""
+
+CFLAGS += " -I${STAGING_INCDIR}"
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}