aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/u-boot/u-boot-imx/mx53_loco_bootenv.patch51
-rw-r--r--recipes-bsp/u-boot/u-boot-imx_2009.08.bb5
2 files changed, 54 insertions, 2 deletions
diff --git a/recipes-bsp/u-boot/u-boot-imx/mx53_loco_bootenv.patch b/recipes-bsp/u-boot/u-boot-imx/mx53_loco_bootenv.patch
new file mode 100644
index 0000000..768cf99
--- /dev/null
+++ b/recipes-bsp/u-boot/u-boot-imx/mx53_loco_bootenv.patch
@@ -0,0 +1,51 @@
+diff --git a/include/configs/mx53_loco.h b/include/configs/mx53_loco.h
+index 0f57f78..e8a6414 100644
+--- a/include/configs/mx53_loco.h
++++ b/include/configs/mx53_loco.h
+@@ -114,22 +114,30 @@
+ #define CONFIG_RD_LOADADDR (CONFIG_LOADADDR + 0x300000)
+
+ #define CONFIG_EXTRA_ENV_SETTINGS \
+- "netdev=eth0\0" \
+- "ethprime=FEC0\0" \
+- "uboot=u-boot.bin\0" \
+- "kernel=uImage\0" \
+- "nfsroot=/opt/eldk/arm\0" \
+- "bootargs_base=setenv bootargs console=ttymxc0,115200\0"\
+- "bootargs_nfs=setenv bootargs ${bootargs} root=/dev/nfs "\
+- "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0"\
+- "bootcmd_net=run bootargs_base bootargs_nfs; " \
+- "tftpboot ${loadaddr} ${kernel}; bootm\0" \
+- "bootargs_mmc=setenv bootargs ${bootargs} ip=dhcp " \
+- "root=/dev/mmcblk0p1 rootwait rw\0" \
+- "bootcmd_mmc=run bootargs_base bootargs_mmc; " \
+- "mmc dev 0; " \
+- "mmc read ${loadaddr} 0x800 0x1800; bootm\0" \
+- "bootcmd=run bootcmd_mmc\0" \
++ "script=boot.scr\0" \
++ "uimage=uImage\0" \
++ "mmcdev=0\0" \
++ "mmcpart=2\0" \
++ "mmcroot=/dev/mmcblk0p3 rw\0" \
++ "mmcrootfstype=ext3 rootwait\0" \
++ "mmcargs=setenv bootargs console=ttymxc0,${baudrate} " \
++ "root=${mmcroot} " \
++ "rootfstype=${mmcrootfstype}\0" \
++ "loadbootscript=" \
++ "fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${script};\0" \
++ "bootscript=echo Running bootscript from mmc ...; " \
++ "source\0" \
++ "loaduimage=fatload mmc ${mmcdev}:${mmcpart} ${loadaddr} ${uimage}\0" \
++ "mmcboot=echo Booting from mmc ...; " \
++ "run mmcargs; " \
++ "bootm\0" \
++ "netargs=setenv bootargs console=ttymxc0,${baudrate} " \
++ "root=/dev/nfs " \
++ "ip=dhcp nfsroot=${serverip}:${nfsroot},v3,tcp\0" \
++ "netboot=echo Booting from net ...; " \
++ "run netargs; " \
++ "dhcp ${uimage}; bootm\0" \
++ "bootcmd=run loaduimage; run mmcboot;\0" \
+ \
+
+
diff --git a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
index 8131a2c..0633284 100644
--- a/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
+++ b/recipes-bsp/u-boot/u-boot-imx_2009.08.bb
@@ -11,9 +11,10 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4c6cde5df68eff615d36789dc18edd3b"
DEPENDS_mxs += "elftosb-native"
-PR = "r4"
+PR = "r5"
-SRC_URI = "git://opensource.freescale.com/pub/scm/imx/uboot-imx.git;tag=rel_imx_2.6.38_11.11.01;protocol=http"
+SRC_URI = "git://opensource.freescale.com/pub/scm/imx/uboot-imx.git;tag=rel_imx_2.6.38_11.11.01;protocol=http \
+ file://mx53_loco_bootenv.patch"
S = "${WORKDIR}/git"