aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-graphics/wayland/weston/0004-Desktop-shell-Don-t-assume-there-is-a-pointer.patch36
-rw-r--r--recipes-graphics/wayland/weston_%.bbappend1
2 files changed, 0 insertions, 37 deletions
diff --git a/recipes-graphics/wayland/weston/0004-Desktop-shell-Don-t-assume-there-is-a-pointer.patch b/recipes-graphics/wayland/weston/0004-Desktop-shell-Don-t-assume-there-is-a-pointer.patch
deleted file mode 100644
index f6ef253..0000000
--- a/recipes-graphics/wayland/weston/0004-Desktop-shell-Don-t-assume-there-is-a-pointer.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 1194ccebc0db14ba681bd8272e01715b3e7008cc Mon Sep 17 00:00:00 2001
-From: Yong Gan <b45748@freescale.com>
-Date: Fri, 27 Jun 2014 11:33:53 +0800
-Subject: [PATCH] ENGR00320189 desktop-shell: Don't assume there is a pointer
- when resizing
-
-Fixes a crash on touch devices without a pointer, when touching
-the window frame of a client.
-cherry-pick from 5872b6821be7c9c0a17a0de962e3f4a04f5d0c6f
-
-Date: Jun 27, 2014
-
-Upstream Status: N/A
-
-Signed-off-by Yong Gan <B45748@freescale.com>
----
- desktop-shell/shell.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/desktop-shell/shell.c b/desktop-shell/shell.c
-index 84f5c83..d965618 100644
---- a/desktop-shell/shell.c
-+++ b/desktop-shell/shell.c
-@@ -1784,7 +1784,8 @@ common_surface_resize(struct wl_resource *resource,
- struct shell_surface *shsurf = wl_resource_get_user_data(resource);
- struct weston_surface *surface;
-
-- if (seat->pointer->button_count == 0 ||
-+ if (seat->pointer == NULL ||
-+ seat->pointer->button_count == 0 ||
- seat->pointer->grab_serial != serial ||
- seat->pointer->focus == NULL)
- return;
---
-1.7.9.5
-
diff --git a/recipes-graphics/wayland/weston_%.bbappend b/recipes-graphics/wayland/weston_%.bbappend
index 7b50283..01773d2 100644
--- a/recipes-graphics/wayland/weston_%.bbappend
+++ b/recipes-graphics/wayland/weston_%.bbappend
@@ -3,7 +3,6 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI_append_mx6 = " file://0001-ENGR00314805-1-Add-Vivante-EGL-support.patch \
file://0002-ENGR00314805-2-Add-Vivante-GAL2D-support.patch \
file://0003-Distorted-line-and-shadow-if-use-2d-com.patch \
- file://0004-Desktop-shell-Don-t-assume-there-is-a-pointer.patch \
file://0005-Enable-GAL2D-compositor-in-SoloLite.patch \
file://0006-Change-GAL2D-compositor-to-be-default-i.patch \
"