aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch50
-rw-r--r--recipes-kernel/linux/linux-imx_3.0.35.bb2
2 files changed, 1 insertions, 51 deletions
diff --git a/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch b/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch
index 5f22380..3e5ea68 100644
--- a/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch
+++ b/recipes-kernel/linux/linux-imx-3.0.35/imx6qsabrelite/sync-boundary-changes.patch
@@ -4994,23 +4994,6 @@ new mode 100644
index 7cf975a..a2589e4
--- a/drivers/input/touchscreen/Kconfig
+++ b/drivers/input/touchscreen/Kconfig
-@@ -199,6 +199,16 @@ config TOUCHSCREEN_ELAN
- To compile this driver as a module, choose M here: the
- module will be called elan-touch.
-
-+config TOUCHSCREEN_EGALAX_SINGLE_TOUCH
-+ bool "EETI eGalax touchscreen as single-touch"
-+ default N
-+ depends on TOUCHSCREEN_EGALAX
-+ help
-+ If you say yes here you get single-touch touchscreen support
-+ on the eGalax I2C controller.
-+ If you say "no", you'll get the normal multi-touch.
-+
-+
- config TOUCHSCREEN_FUJITSU
- tristate "Fujitsu serial touchscreen"
- select SERIO
@@ -282,6 +292,22 @@ config TOUCHSCREEN_MAX11801
To compile this driver as a module, choose M here: the
module will be called max11801_ts.
@@ -5075,39 +5058,6 @@ index e614512..eac3453
diff --git a/drivers/input/touchscreen/da9052_tsi_filter.c b/drivers/input/touchscreen/da9052_tsi_filter.c
old mode 100755
new mode 100644
-diff --git a/drivers/input/touchscreen/egalax_ts.c b/drivers/input/touchscreen/egalax_ts.c
-index fff8afe..0b6cde7 100644
---- a/drivers/input/touchscreen/egalax_ts.c
-+++ b/drivers/input/touchscreen/egalax_ts.c
-@@ -139,7 +139,7 @@ retry:
- events[id].x = x;
- events[id].y = y;
-
--#ifdef FORCE_SINGLE_POINTER_SUPPORT
-+#ifdef CONFIG_TOUCHSCREEN_EGALAX_SINGLE_TOUCH
- input_report_abs(input_dev, ABS_X, x);
- input_report_abs(input_dev, ABS_Y, y);
- input_event(data->input_dev, EV_KEY, BTN_TOUCH, 1);
-@@ -166,7 +166,7 @@ retry:
- dev_dbg(&client->dev, "release id:%d\n", id);
- events[id].valid = 0;
- events[id].status = 0;
--#ifdef FORCE_SINGLE_POINTER_SUPPORT
-+#ifdef CONFIG_TOUCHSCREEN_EGALAX_SINGLE_TOUCH
- input_report_key(input_dev, BTN_TOUCH, 0);
- input_report_abs(input_dev, ABS_PRESSURE, 0);
- #else
-@@ -256,8 +256,9 @@ static int __devinit egalax_ts_probe(struct i2c_client *client,
- __set_bit(ABS_PRESSURE, input_dev->absbit);
- input_set_abs_params(input_dev, ABS_X, 0, 32767, 0, 0);
- input_set_abs_params(input_dev, ABS_Y, 0, 32767, 0, 0);
-+ input_set_abs_params(input_dev, ABS_PRESSURE, 0, 1, 0, 0);
-
--#ifndef FORCE_SINGLE_POINTER_SUPPORT
-+#ifndef CONFIG_TOUCHSCREEN_EGALAX_SINGLE_TOUCH
- input_set_abs_params(input_dev, ABS_MT_POSITION_X, 0, 32767, 0, 0);
- input_set_abs_params(input_dev, ABS_MT_POSITION_Y, 0, 32767, 0, 0);
- input_set_abs_params(input_dev, ABS_MT_TOUCH_MAJOR, 0, 255, 0, 0);
diff --git a/drivers/input/touchscreen/ft5x06_ts.c b/drivers/input/touchscreen/ft5x06_ts.c
new file mode 100644
index 0000000..89b5726
diff --git a/recipes-kernel/linux/linux-imx_3.0.35.bb b/recipes-kernel/linux/linux-imx_3.0.35.bb
index 9c4b0be..149366b 100644
--- a/recipes-kernel/linux/linux-imx_3.0.35.bb
+++ b/recipes-kernel/linux/linux-imx_3.0.35.bb
@@ -3,7 +3,7 @@
include linux-imx.inc
-PR = "${INC_PR}.8"
+PR = "${INC_PR}.9"
COMPATIBLE_MACHINE = "(mx6)"