aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-fslc-imx/defconfig8
-rw-r--r--recipes-kernel/linux/linux-fslc-imx_4.1-1.0.x.bb4
2 files changed, 7 insertions, 5 deletions
diff --git a/recipes-kernel/linux/linux-fslc-imx/defconfig b/recipes-kernel/linux/linux-fslc-imx/defconfig
index df7d7f4..5742425 100644
--- a/recipes-kernel/linux/linux-fslc-imx/defconfig
+++ b/recipes-kernel/linux/linux-fslc-imx/defconfig
@@ -144,10 +144,10 @@ CONFIG_USB_RTL8150=m
CONFIG_USB_RTL8152=m
CONFIG_USB_USBNET=m
CONFIG_USB_NET_CDC_EEM=m
-CONFIG_BCMDHD=m
+CONFIG_BCMDHD=y
CONFIG_BCMDHD_SDIO=y
-CONFIG_BCMDHD_FW_PATH="/lib/firmware/bcm/fw_bcmdhd.bin"
-CONFIG_BCMDHD_NVRAM_PATH="/lib/firmware/bcm/bcmdhd.cal"
+CONFIG_BCMDHD_FW_PATH="/lib/firmware/bcm/ZP_BCM4339/fw_bcmdhd.bin"
+CONFIG_BCMDHD_NVRAM_PATH="/lib/firmware/bcm/ZP_BCM4339/bcmdhd.ZP.SDIO.cal"
# CONFIG_RTL_CARDS is not set
# CONFIG_INPUT_MOUSEDEV_PSAUX is not set
CONFIG_INPUT_EVDEV=y
@@ -254,6 +254,8 @@ CONFIG_FB_MXC_SYNC_PANEL=y
CONFIG_FB_MXC_MIPI_DSI=y
CONFIG_FB_MXC_MIPI_DSI_SAMSUNG=y
CONFIG_FB_MXC_TRULY_WVGA_SYNC_PANEL=y
+CONFIG_FB_MXC_TRULY_PANEL_TFT3P5079E=y
+CONFIG_FB_MXC_TRULY_PANEL_TFT3P5581E=y
CONFIG_FB_MXC_LDB=y
CONFIG_FB_MXC_HDMI=y
CONFIG_FB_MXS_SII902X=y
diff --git a/recipes-kernel/linux/linux-fslc-imx_4.1-1.0.x.bb b/recipes-kernel/linux/linux-fslc-imx_4.1-1.0.x.bb
index 7014134..445db76 100644
--- a/recipes-kernel/linux/linux-fslc-imx_4.1-1.0.x.bb
+++ b/recipes-kernel/linux/linux-fslc-imx_4.1-1.0.x.bb
@@ -2,7 +2,7 @@
# Released under the MIT license (see COPYING.MIT for the terms)
SUMMARY = "FSL Community BSP i.MX6 Linux kernel with backported features and fixes"
-DESCRIPTION = "Linux kernel based on NXP 4.1.15-1.0.0 GA release, used by FSL Community BSP in order to \
+DESCRIPTION = "Linux kernel based on NXP 4.1.15-1.2.0 GA release, used by FSL Community BSP in order to \
provide support for i.MX6 based platforms and include official Linux kernel stable updates, backported \
features and fixes coming from the vendors, kernel community or FSL Community itself."
@@ -11,6 +11,6 @@ include linux-fslc.inc
PV .= "+git${SRCPV}"
SRCBRANCH = "4.1-1.0.x-imx"
-SRCREV = "960f493cce161ddc2ba3ffe82c061496e5771829"
+SRCREV = "3477bd7c6da28563567d4cce98582ea6b21f354e"
COMPATIBLE_MACHINE = "(mx6|mx7)"