aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-qt/qt4/qt4-x11-free_4.8.5.bbappend2
-rw-r--r--recipes-qt/qt4/qt4/0003-i.MX6-force-egl-visual-ID-33.patch35
2 files changed, 37 insertions, 0 deletions
diff --git a/recipes-qt/qt4/qt4-x11-free_4.8.5.bbappend b/recipes-qt/qt4/qt4-x11-free_4.8.5.bbappend
index 7090bed..cf763b6 100644
--- a/recipes-qt/qt4/qt4-x11-free_4.8.5.bbappend
+++ b/recipes-qt/qt4/qt4-x11-free_4.8.5.bbappend
@@ -11,3 +11,5 @@ QT_CONFIG_FLAGS_append_mx6 = " -I${STAGING_KERNEL_DIR}/include/uapi \
-I${STAGING_KERNEL_DIR}/include/ \
-DLINUX=1 -DEGL_API_FB=1 \
-DQT_QPA_EXPERIMENTAL_TOUCHEVENT=1"
+
+SRC_URI_append_mx6 = " file://0003-i.MX6-force-egl-visual-ID-33.patch"
diff --git a/recipes-qt/qt4/qt4/0003-i.MX6-force-egl-visual-ID-33.patch b/recipes-qt/qt4/qt4/0003-i.MX6-force-egl-visual-ID-33.patch
new file mode 100644
index 0000000..9aa158d
--- /dev/null
+++ b/recipes-qt/qt4/qt4/0003-i.MX6-force-egl-visual-ID-33.patch
@@ -0,0 +1,35 @@
+From: Javier Viguera <javier.viguera@digi.com>
+Date: Mon, 3 Mar 2014 17:10:41 +0100
+Subject: [PATCH] i.MX6: force egl visual ID 33
+
+Workaround mismatch between EGL binary libraries and QT for FSL MX6
+based platforms.
+
+Error:
+Warning: EGL suggested using X Visual ID 33 (ARGB0888) for EGL config 28 (ARGB0444), but this is incompatable
+Unable to find an X11 visual which matches EGL config 28
+
+Patch adapted from:
+
+http://wiki.wandboard.org/index.php/Integrate_Qt5_into_yocto_sato_image_on_Wandboard
+
+Upstream-Status: Inappropriate [workaround]
+
+Signed-off-by: Javier Viguera <javier.viguera@digi.com>
+---
+ src/gui/egl/qegl_x11.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/gui/egl/qegl_x11.cpp b/src/gui/egl/qegl_x11.cpp
+index 196d0f77bf2d..8acf5a6c99d4 100644
+--- a/src/gui/egl/qegl_x11.cpp
++++ b/src/gui/egl/qegl_x11.cpp
+@@ -319,7 +319,7 @@ VisualID QEgl::getCompatibleVisualId(EGLConfig config)
+ }
+
+ qWarning("Unable to find an X11 visual which matches EGL config %d", configId);
+- return (VisualID)0;
++ return (VisualID)33;
+ }
+
+ void qt_set_winid_on_widget(QWidget* w, Qt::HANDLE id)