aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/gstreamer/gst-fsl-plugin.inc6
-rw-r--r--recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch63
-rw-r--r--recipes-multimedia/gstreamer/gst-fsl-plugin_3.0.9.bb3
3 files changed, 67 insertions, 5 deletions
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin.inc b/recipes-multimedia/gstreamer/gst-fsl-plugin.inc
index e179c76..5331887 100644
--- a/recipes-multimedia/gstreamer/gst-fsl-plugin.inc
+++ b/recipes-multimedia/gstreamer/gst-fsl-plugin.inc
@@ -26,10 +26,8 @@ PLATFORM_mx6sl = "MX6SL"
PLATFORM_mx28 = "MX28"
# Todo add a mechanism to map posible build targets
-INCLUDE_DIR = "-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include"
-EXTRA_OEMAKE = "INCLUDES="${INCLUDE_DIR}""
-EXTRA_OECONF = "PLATFORM=${PLATFORM} --disable-valgrind --disable-examples --disable-debug CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR}"
-CACHED_CONFIGUREVARS += "CROSS_ROOT=${STAGING_DIR_TARGET}"
+EXTRA_OECONF = "PLATFORM=${PLATFORM} --disable-valgrind --disable-examples --disable-debug \
+ CPPFLAGS="-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include""
PACKAGES += "${PN}-libmfwsconf ${PN}-libgplaycore ${PN}-libgstfsl \
${PN}-libme ${PN}-libgstbufmeta ${PN}-libmfwba \
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch b/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch
new file mode 100644
index 0000000..02b5208
--- /dev/null
+++ b/recipes-multimedia/gstreamer/gst-fsl-plugin/configure.ac-Fix-checking-for-include-headers-in-mul.patch
@@ -0,0 +1,63 @@
+From be38dc1816d4de1a1b463988763f50226eb8417f Mon Sep 17 00:00:00 2001
+From: Otavio Salvador <otavio@ossystems.com.br>
+Date: Thu, 7 Nov 2013 10:50:51 -0200
+Subject: [PATCH] configure.ac: Fix checking for include headers in multiple
+ paths
+Organization: O.S. Systems Software LTDA.
+
+This fixes the support for proper detecting Freescale specific headers
+in include/linux and include/uapi.
+
+Without this patch we have the configure log with the same feature in
+'enabled' and 'disabled' state and it was impossible to override the
+CPPFLAGS.
+
+Upstream-Status: Pending
+
+Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
+---
+ configure.ac | 19 ++++++++-----------
+ 1 file changed, 8 insertions(+), 11 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index d74ee0e..f11c76c 100755
+--- a/configure.ac
++++ b/configure.ac
+@@ -58,13 +58,9 @@ AC_DEFUN([CHECK_DISABLE_FEATURE],
+ [use_[$1]=$enableval],
+ [use_[$1]=yes])
+ if test "$use_[$1]" = "yes"; then
+- SAVE_CPPFLAGS="$CPPFLAGS"
+- CPPFLAGS=`$PKG_CONFIG --cflags libfslaudiocodec`
+- CPPFLAGS+=`$PKG_CONFIG --cflags libfslvideocodec`
+- CPPFLAGS+=`$PKG_CONFIG --cflags libfslparser`
+- CPPFLAGS+=`$PKG_CONFIG --cflags libfslvpuwrap`
+- AC_CHECK_HEADERS([$4], HAVE_[$3]=yes, HAVE_[$3]=no && break)
+- CPPFLAGS="$SAVE_CPPFLAGS"
++ for h in "$4"; do
++ AC_CHECK_HEADERS([$h], HAVE_[$3]=yes && break, HAVE_[$3]=no)
++ done
+ if test "x$HAVE_[$3]" = "xyes"; then
+ enabled_feature="$enabled_feature\n\t\t[$5]"
+ else
+@@ -283,12 +279,13 @@ CHECK_DISABLE_FEATURE(beep, [Disable beep audio decoder], [BEEP], [fsl_unia.h],
+
+ CHECK_DISABLE_FEATURE(v4lsink, [Disable fsl v4l sink], [V4L_SINK], [linux/videodev2.h], [plugin: v4lsink])
+
++# Allow headers to be inside include/uapi and include/linux
+ saved_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $IPU_CFLAGS"
+-CHECK_DISABLE_FEATURE(isink, [Disable fsl ipu sink], [I_SINK], [linux/mxcfb.h], [plugin: isink])
+-CHECK_DISABLE_FEATURE(isink, [Disable fsl ipu sink], [I_SINK], [uapi/mxcfb.h], [plugin: isink])
+-CHECK_DISABLE_FEATURE(ipucsc, [Disable fsl ipu csc], [I_CSC], [linux/mxcfb.h], [plugin: ipucsc])
+-CHECK_DISABLE_FEATURE(ipucsc, [Disable fsl ipu csc], [I_CSC], [uapi/mxcfb.h], [plugin: ipucsc])
++
++CHECK_DISABLE_FEATURE(isink, [Disable fsl ipu sink], [I_SINK], [linux/mxcfb.h uapi/mxcfb.h], [plugin: isink])
++CHECK_DISABLE_FEATURE(ipucsc, [Disable fsl ipu csc], [I_CSC], [linux/mxcfb.h uapi/mxcfb.h], [plugin: ipucsc])
++
+ CFLAGS=$saved_CFLAGS
+
+ CHECK_DISABLE_FEATURE(ipulib, [Disable ipu lib], [IPU_LIB], [mxc_ipu_hl_lib.h], [library: libipu])
+--
+1.8.4.rc3
+
diff --git a/recipes-multimedia/gstreamer/gst-fsl-plugin_3.0.9.bb b/recipes-multimedia/gstreamer/gst-fsl-plugin_3.0.9.bb
index 52813a5..fc9b38f 100644
--- a/recipes-multimedia/gstreamer/gst-fsl-plugin_3.0.9.bb
+++ b/recipes-multimedia/gstreamer/gst-fsl-plugin_3.0.9.bb
@@ -5,7 +5,8 @@ require gst-fsl-plugin.inc
# FIXME: Inspecting the source code the content is in fact 3.0.9
SRC_URI = "${FSL_MIRROR}/gst-fsl-plugins-3.10.9-1.0.0.tar.gz \
- file://remove-GST_INFO-in-mfw_gst_utils.h.patch"
+ file://remove-GST_INFO-in-mfw_gst_utils.h.patch \
+ file://configure.ac-Fix-checking-for-include-headers-in-mul.patch"
SRC_URI[md5sum] = "a338a5c25225c765ae5f44af82fe7413"
SRC_URI[sha256sum] = "e809daa0cd60381f05a79f34a53305a5ee53bfed22192a1cda6d998acc84a6fd"