aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-multimedia/gst-plugins/gst-fsl-plugin.inc10
-rw-r--r--recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch58
-rw-r--r--recipes-multimedia/gst-plugins/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch40
-rw-r--r--recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.8.bb15
-rw-r--r--recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.9.bb15
5 files changed, 61 insertions, 77 deletions
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin.inc b/recipes-multimedia/gst-plugins/gst-fsl-plugin.inc
index 1425445..e179c76 100644
--- a/recipes-multimedia/gst-plugins/gst-fsl-plugin.inc
+++ b/recipes-multimedia/gst-plugins/gst-fsl-plugin.inc
@@ -7,7 +7,8 @@ SECTION = "multimedia"
DEPENDS = "gstreamer gst-plugins-base libfslcodec libfslparser virtual/kernel"
DEPENDS_append_mx5 = " imx-lib imx-vpu"
-DEPENDS_append_mx6 = " imx-lib libfslvpuwrap"
+DEPENDS_append_mx6 = " imx-lib imx-vpu libfslvpuwrap"
+DEPENDS_append_mx6sl = " imx-lib"
LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
file://COPYING-LGPL-2;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
@@ -21,12 +22,13 @@ inherit autotools pkgconfig
PLATFORM_mx5 = "MX51"
PLATFORM_mx6 = "MX6"
+PLATFORM_mx6sl = "MX6SL"
PLATFORM_mx28 = "MX28"
# Todo add a mechanism to map posible build targets
-INCLUDE_DIR = "-I${STAGING_KERNEL_DIR}/include"
-EXTRA_OEMAKE = "INCLUDES=${INCLUDE_DIR}"
-EXTRA_OECONF = "PLATFORM=${PLATFORM} --disable-valgrind --disable-examples --disable-debug"
+INCLUDE_DIR = "-I${STAGING_KERNEL_DIR}/include/uapi -I${STAGING_KERNEL_DIR}/include"
+EXTRA_OEMAKE = "INCLUDES="${INCLUDE_DIR}""
+EXTRA_OECONF = "PLATFORM=${PLATFORM} --disable-valgrind --disable-examples --disable-debug CROSS_ROOT=${PKG_CONFIG_SYSROOT_DIR}"
CACHED_CONFIGUREVARS += "CROSS_ROOT=${STAGING_DIR_TARGET}"
PACKAGES += "${PN}-libmfwsconf ${PN}-libgplaycore ${PN}-libgstfsl \
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch b/recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch
deleted file mode 100644
index cab9ff4..0000000
--- a/recipes-multimedia/gst-plugins/gst-fsl-plugin/configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 6f75a9f4ad108c1f4a3dff4dd08def174ab83a69 Mon Sep 17 00:00:00 2001
-From: Otavio Salvador <otavio@ossystems.com.br>
-Date: Tue, 21 May 2013 16:43:31 -0300
-Subject: [PATCH] configure.ac: Use pkg-config sysroot when checking for soname
-
-Upstream-Status: Pending
-
-Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
----
- configure.ac | 12 +++++-------
- 1 file changed, 5 insertions(+), 7 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index e4cdb86..c12ceb4 100755
---- a/configure.ac
-+++ b/configure.ac
-@@ -16,7 +16,7 @@ AC_DEFUN([FIND_PARSER_SONAME],
- [
- AC_MSG_CHECKING([for lib_$1_parser_$2_elinux.3.0.so soname])
- path=`$PKG_CONFIG --variable=libdir libfslparser`
-- SONAME=$( $CC -print-file-name=$path/lib_$1_parser_$2_elinux.so | \
-+ SONAME=$( $CC -print-file-name=$PKG_CONFIG_SYSROOT_DIR$path/lib_$1_parser_$2_elinux.so | \
- while read output; do objdump -p $output | \
- grep "SONAME" | \
- sed -e 's/ \+SONAME \+//'; done 2> /dev/null )
-@@ -27,16 +27,15 @@ AC_DEFUN([FIND_PARSER_SONAME],
- else
- AC_MSG_RESULT([$SONAME])
- fi
-- apath=`echo $path | sed -e 's|.*/imx-mm/|/usr/lib/imx-mm/|'`
-- $1_$2_SONAME=$apath/$SONAME
-+ $1_$2_SONAME=$path/$SONAME
- AC_SUBST($1_$2_SONAME)
- ])
-
- AC_DEFUN([FIND_ACODEC_SONAME],
- [
- AC_MSG_CHECKING([for lib_$1_wrap_$2_elinux.so soname])
-- path=`$PKG_CONFIG --variable=libdir libfslaudiocodec | sed -e 's|.*/imx-mm/|/usr/lib/imx-mm/|'`
-- SONAME=$( $CC -print-file-name=$path/wrap/lib_$1_wrap_$2_elinux.so | \
-+ path=`$PKG_CONFIG --variable=libdir libfslaudiocodec`
-+ SONAME=$( $CC -print-file-name=$PKG_CONFIG_SYSROOT_DIR$path/wrap/lib_$1_wrap_$2_elinux.so | \
- while read output; do objdump -p $output | \
- grep "SONAME" | \
- sed -e 's/ \+SONAME \+//'; done 2> /dev/null )
-@@ -48,8 +47,7 @@ AC_DEFUN([FIND_ACODEC_SONAME],
- AC_MSG_RESULT([$SONAME])
- fi
-
-- apath=`echo $path | sed -e 's|.*/imx-mm/|/usr/lib/imx-mm/|'`
-- $1_$2_SONAME=$apath/wrap/$SONAME
-+ $1_$2_SONAME=$path/wrap/$SONAME
- AC_SUBST($1_$2_SONAME)
- ])
-
---
-1.8.1
-
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch b/recipes-multimedia/gst-plugins/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch
new file mode 100644
index 0000000..e06a250
--- /dev/null
+++ b/recipes-multimedia/gst-plugins/gst-fsl-plugin/remove-GST_INFO-in-mfw_gst_utils.h.patch
@@ -0,0 +1,40 @@
+From 28ad25933dc51d8af13927a9943a353677c31a3a Mon Sep 17 00:00:00 2001
+From: Lyon Wang <lyon.wang@freescale.com>
+Date: Tue, 22 Oct 2013 16:15:43 +0800
+Subject: [PATCH] remove GST_INFO in mfw_gst_utils.h
+
+GST_INFO() should not be used in the global header
+or it will cause some macro definiation error.
+
+so comment the GST_INFO() in the mfw_gst_utils.h
+
+Upstream-Status: Backport [GIT]
+---
+ inc/plugin/mfw_gst_utils.h | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/inc/plugin/mfw_gst_utils.h b/inc/plugin/mfw_gst_utils.h
+index 366d50e..c1b6f90 100755
+--- a/inc/plugin/mfw_gst_utils.h
++++ b/inc/plugin/mfw_gst_utils.h
+@@ -876,7 +876,7 @@ getChipCodeFromSocid (void)
+ }
+ fclose(fp);
+
+- GST_INFO("SOC is %s\n", soc_name);
++ //GST_INFO("SOC is %s\n", soc_name);
+
+ int num = sizeof(soc_info) / sizeof(SOC_INFO);
+ int i;
+@@ -913,7 +913,7 @@ getChipCode (void)
+ }
+
+ kv = ((kv_major << 16) + (kv_minor << 8) + kv_rel);
+- GST_INFO("kernel:%s, %d.%d.%d\n", sys_name.release, kv_major, kv_minor, kv_rel);
++ //GST_INFO("kernel:%s, %d.%d.%d\n", sys_name.release, kv_major, kv_minor, kv_rel);
+
+ if (kv < KERN_VER(3, 10, 0))
+ return getChipCodeFromCpuinfo();
+--
+1.7.9.5
+
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.8.bb b/recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.8.bb
deleted file mode 100644
index ea0d26e..0000000
--- a/recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.8.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-# Copyright (C) 2012-2013 Freescale Semiconductor
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-require gst-fsl-plugin.inc
-
-SRC_URI[md5sum] = "fe298c831e107ae5b93df05c4c29bb65"
-SRC_URI[sha256sum] = "6c3215f24dedabf97ad6a7bd5c8d088b01dc4cd4792c56e0df353ae03adb35ff"
-
-# FIXME: Inspecting the source code the content is in fact 3.0.8
-SRC_URI = "${FSL_MIRROR}/gst-fsl-plugins-3.5.7-1.0.0.tar.gz"
-S = "${WORKDIR}/gst-fsl-plugins-3.5.7-1.0.0"
-
-SRC_URI_append += "file://configure.ac-Use-pkg-config-sysroot-when-checking-fo.patch"
-
-COMPATIBLE_MACHINE = "(mx28|mx5|mx6)"
diff --git a/recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.9.bb b/recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.9.bb
new file mode 100644
index 0000000..52813a5
--- /dev/null
+++ b/recipes-multimedia/gst-plugins/gst-fsl-plugin_3.0.9.bb
@@ -0,0 +1,15 @@
+# Copyright (C) 2013 Freescale Semiconductor
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require gst-fsl-plugin.inc
+
+# FIXME: Inspecting the source code the content is in fact 3.0.9
+SRC_URI = "${FSL_MIRROR}/gst-fsl-plugins-3.10.9-1.0.0.tar.gz \
+ file://remove-GST_INFO-in-mfw_gst_utils.h.patch"
+
+SRC_URI[md5sum] = "a338a5c25225c765ae5f44af82fe7413"
+SRC_URI[sha256sum] = "e809daa0cd60381f05a79f34a53305a5ee53bfed22192a1cda6d998acc84a6fd"
+
+S = "${WORKDIR}/gst-fsl-plugins-3.10.9-1.0.0"
+
+COMPATIBLE_MACHINE = "(mx28|mx5|mx6)"