aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch24
-rw-r--r--recipes-bsp/apptrk/apptrk/no-strip.patch20
-rw-r--r--recipes-bsp/apptrk/apptrk_git.bb24
3 files changed, 68 insertions, 0 deletions
diff --git a/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch b/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch
new file mode 100644
index 0000000..6b4a0e8
--- /dev/null
+++ b/recipes-bsp/apptrk/apptrk/apptrk-install-create-all-components-of-DEST.patch
@@ -0,0 +1,24 @@
+Upstream-Status: Pending
+
+Signed-off-by: Chunrong Guo <B40290@freescale.com>
+
+
+ for fix the following error:
+ |install: cannot create regular file /usr/bin/apptrk
+ |No such file or directory
+
+
+--- a/Makefileold 2014-12-21 23:46:26.872329032 -0600
++++ b/Makefile 2014-12-21 23:47:33.724326646 -0600
+@@ -89,9 +89,9 @@
+ # Other Targets
+ install: all
+ if [ -f $(DESTDIR)/usr/bin/apptrk ]; then rm -f $(DESTDIR)/usr/bin/apptrk ; fi
+- install $(OUTPUT) $(DESTDIR)/usr/bin/apptrk
++ install -D $(OUTPUT) $(DESTDIR)/usr/bin/apptrk
+ if [ -f $(DESTDIR)/usr/bin/apptrk_debug ]; then rm -f $(DESTDIR)/usr/bin/apptrk_debug ; fi
+- install $(OUTPUT_DBG) $(DESTDIR)/usr/bin/apptrk_debug
++ install -D $(OUTPUT_DBG) $(DESTDIR)/usr/bin/apptrk_debug
+
+ clean:
+ -$(RM) $(OBJS)$(OBJS_DBG)$(EXECUTABLES)$(C_DEPS)$(C_DEPS_DBG) $(OUTPUT) $(OUTPUT_DBG)
diff --git a/recipes-bsp/apptrk/apptrk/no-strip.patch b/recipes-bsp/apptrk/apptrk/no-strip.patch
new file mode 100644
index 0000000..a8cf620
--- /dev/null
+++ b/recipes-bsp/apptrk/apptrk/no-strip.patch
@@ -0,0 +1,20 @@
+Disable stripping of binaries
+
+We don't want to strip these as this is handled separately at package
+time.
+
+Upstream-Status: Inappropriate [configuration]
+
+Signed-off-by: Chunrong Guo <B40290@freescale.com>
+
+--- a/Makefileold 2015-01-07 03:45:32.786477574 -0600
++++ b/Makefile 2015-01-07 03:46:28.426475588 -0600
+@@ -62,7 +62,7 @@
+ # CFLAGS += -DENABLE_64BIT_SUPPORT
+
+
+-LDFLAGS += -s
++
+
+ # Add inputs and outputs from these tool invocations to the build variables
+
diff --git a/recipes-bsp/apptrk/apptrk_git.bb b/recipes-bsp/apptrk/apptrk_git.bb
new file mode 100644
index 0000000..4453cf8
--- /dev/null
+++ b/recipes-bsp/apptrk/apptrk_git.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Debug agent for Freescale CodeWarrior"
+SECTION = "apptrk"
+LICENSE = "Freescale-EULA"
+LIC_FILES_CHKSUM = "file://COPYING;md5=95560debfde180684364319811cc1421"
+
+DEPENDS = "elfutils"
+
+inherit kernel-arch
+
+SRC_URI = "git://git.freescale.com/ppc/sdk/apptrk.git;nobranch=1 \
+ file://apptrk-install-create-all-components-of-DEST.patch \
+ file://no-strip.patch \
+"
+SRCREV = "cbed10997c5e2a4aaa004fb0e1efec858bf1bbe1"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = ""
+
+CFLAGS += " -I${STAGING_INCDIR}"
+
+do_install() {
+ oe_runmake install DESTDIR=${D}
+}