aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/0001-mx53_loco-add-USR-led-support.patch68
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/devtmpfs-init-options-alignment.patch38
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/plat-mxc-double-dma-zone-max.patch35
-rw-r--r--recipes-kernel/linux/linux-imx/egalax_ts-enable-single-event-support.patch30
-rw-r--r--recipes-kernel/linux/linux-imx_2.6.35.3.bb11
5 files changed, 3 insertions, 179 deletions
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/0001-mx53_loco-add-USR-led-support.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/0001-mx53_loco-add-USR-led-support.patch
deleted file mode 100644
index 1eff494..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/0001-mx53_loco-add-USR-led-support.patch
+++ /dev/null
@@ -1,68 +0,0 @@
-From 564ac4b9d7da4cc8e6fdca33ca45d19649dc3366 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Eric=20B=C3=A9nard?= <eric@eukrea.com>
-Date: Wed, 7 Mar 2012 23:24:54 +0100
-Subject: [PATCH] mx53_loco: add USR led support
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Eric Bénard <eric@eukrea.com>
----
- arch/arm/mach-mx5/mx53_loco.c | 27 +++++++++++++++++++++++++++
- 1 files changed, 27 insertions(+), 0 deletions(-)
-
-diff --git a/arch/arm/mach-mx5/mx53_loco.c b/arch/arm/mach-mx5/mx53_loco.c
-index c8417da..c91952b 100644
---- a/arch/arm/mach-mx5/mx53_loco.c
-+++ b/arch/arm/mach-mx5/mx53_loco.c
-@@ -835,6 +835,28 @@ static void __init fixup_mxc_board(struct machine_desc *desc, struct tag *tags,
- }
- }
-
-+static struct gpio_led gpio_leds[] = {
-+ {
-+ .name = "USR",
-+ .default_trigger = "heartbeat",
-+ .active_low = 0,
-+ .gpio = USER_LED_EN,
-+ },
-+};
-+
-+static struct gpio_led_platform_data gpio_led_info = {
-+ .leds = gpio_leds,
-+ .num_leds = ARRAY_SIZE(gpio_leds),
-+};
-+
-+static struct platform_device leds_gpio = {
-+ .name = "leds-gpio",
-+ .id = -1,
-+ .dev = {
-+ .platform_data = &gpio_led_info,
-+ },
-+};
-+
- static void __init mx53_loco_io_init(void)
- {
- mxc_iomux_v3_setup_multiple_pads(mx53_loco_pads,
-@@ -865,6 +887,10 @@ static void __init mx53_loco_io_init(void)
- gpio_request(DISP0_POWER_EN, "disp0-power-en");
- gpio_direction_output(DISP0_POWER_EN, 1);
-
-+ /* USR LED */
-+ gpio_request(USER_LED_EN, "user-led-en");
-+ gpio_direction_output(USER_LED_EN, 1);
-+ gpio_free(USER_LED_EN);
- }
-
- /*!
-@@ -979,6 +1005,7 @@ static void __init mxc_board_init(void)
- loco_add_device_buttons();
- pm_power_off = da9053_power_off;
- pm_i2c_init(I2C1_BASE_ADDR - MX53_OFFSET);
-+ platform_device_register(&leds_gpio);
- }
-
- static void __init mx53_loco_timer_init(void)
---
-1.7.7.6
-
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/devtmpfs-init-options-alignment.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/devtmpfs-init-options-alignment.patch
deleted file mode 100644
index 19e5ef2..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/devtmpfs-init-options-alignment.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-Make the devtmpfs options static. This works around an issue that is still
-under investigation.
-
-The toolchain assumes it can generate unaligned accesses for ARMv6+, as these
-cores can handle this, PROVIDED the bit is set in the CP15 control register.
-
-However, Linux sets this bit lazely (upon first trap), which does not work for
-kernel space code.
-
-There was a lengthy thread over this, the agreement was the kernel should not
-have non-aligned structures on stacks anyway.
-
-Forcing this structure to be aligned on the stack did not help, unsure why.
-This requires further investigation.
-
-This fixes a kernel failure if devtmpfs was enabled in the kernel config.
-
-Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
-diff -Nur orig/drivers/base/devtmpfs.c git/drivers/base/devtmpfs.c
---- orig/drivers/base/devtmpfs.c 2011-12-22 15:11:18.752904263 +0100
-+++ git/drivers/base/devtmpfs.c 2011-12-22 18:03:09.060928840 +0100
-@@ -365,6 +365,8 @@
- return err;
- }
-
-+static char options[] = "mode=0755";
-+
- /*
- * Create devtmpfs instance, driver-core devices will add their device
- * nodes here.
-@@ -373,7 +375,6 @@
- {
- int err;
- struct vfsmount *mnt;
-- char options[] = "mode=0755";
-
- err = register_filesystem(&dev_fs_type);
- if (err) {
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/plat-mxc-double-dma-zone-max.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/plat-mxc-double-dma-zone-max.patch
deleted file mode 100644
index cd13000..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/plat-mxc-double-dma-zone-max.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-Double the maximum value of DMA_ZONE_SIZE for i.MX (plat-mxc).
-
-This allows to increase the DMA_ZONE, which prevents memory allocation
-failures during playout V4L2, such as these:
-
-gplay: page allocation failure. order:10, mode:0xd1
-[<80038538>] (unwind_backtrace+0x0/0xf0) from [<8009c4c8>] (__alloc_pages_nodemask+0x500/0x568)
-[<8009c4c8>] (__alloc_pages_nodemask+0x500/0x568) from [<80038f70>] (__dma_alloc+0xec/0x2b8)
-[<80038f70>] (__dma_alloc+0xec/0x2b8) from [<800391b4>] (dma_alloc_coherent+0x54/0x60)
-[<800391b4>] (dma_alloc_coherent+0x54/0x60) from [<802e40b8>] (mxc_allocate_buffers+0x24/0x7c)
-[<802e40b8>] (mxc_allocate_buffers+0x24/0x7c) from [<802e6098>] (mxc_v4l2out_do_ioctl+0x488/0xd9c)
-[<802e6098>] (mxc_v4l2out_do_ioctl+0x488/0xd9c) from [<802d945c>] (video_usercopy+0x1e4/0x310)
-[<802d945c>] (video_usercopy+0x1e4/0x310) from [<802d889c>] (v4l2_ioctl+0x44/0x4c)
-[<802d889c>] (v4l2_ioctl+0x44/0x4c) from [<800d0bb4>] (vfs_ioctl+0x7c/0xac)
-[<800d0bb4>] (vfs_ioctl+0x7c/0xac) from [<800d1204>] (do_vfs_ioctl+0x52c/0x57c)
-[<800d1204>] (do_vfs_ioctl+0x52c/0x57c) from [<800d1288>] (sys_ioctl+0x34/0x54)
-[<800d1288>] (sys_ioctl+0x34/0x54) from [<80033f80>] (ret_fast_syscall+0x0/0x30)
-
-Although this fixes first symptoms, needs further analysis to see if this is
-a long term fix. Is this contiguous memory? Does it fragment over time, thus
-only delay the actual error occurance, etc?
-
-Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
-diff -Nur orig/arch/arm/plat-mxc/Kconfig git/arch/arm/plat-mxc/Kconfig
---- orig/arch/arm/plat-mxc/Kconfig 2011-12-22 15:11:17.589371026 +0100
-+++ git/arch/arm/plat-mxc/Kconfig 2011-12-22 16:10:19.148873805 +0100
-@@ -87,7 +87,7 @@
-
- config DMA_ZONE_SIZE
- int "DMA memory zone size"
-- range 0 96
-+ range 0 182
- default 24
- help
- This is the size in MB for the DMA zone. The DMA zone is used for
diff --git a/recipes-kernel/linux/linux-imx/egalax_ts-enable-single-event-support.patch b/recipes-kernel/linux/linux-imx/egalax_ts-enable-single-event-support.patch
deleted file mode 100644
index e07a15d..0000000
--- a/recipes-kernel/linux/linux-imx/egalax_ts-enable-single-event-support.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From ebe473696da4f4de48b973c93c8bd32300baa818 Mon Sep 17 00:00:00 2001
-From: Adrian Alonso <b38018@freescale.com>
-Date: Wed, 24 Aug 2011 16:11:14 -0500
-Subject: [PATCH] egalax_ts: enable single event support
-
-* Enable single event support for Ubuntu and
- Sato desktop touchscreen support
-
-Signed-off-by: Adrian Alonso <b38018@freescale.com>
----
- drivers/input/touchscreen/egalax_ts.c | 3 +++
- 1 files changed, 3 insertions(+), 0 deletions(-)
-
-diff --git a/drivers/input/touchscreen/egalax_ts.c b/drivers/input/touchscreen/egalax_ts.c
-index 58273b9..05c9c49 100644
---- a/drivers/input/touchscreen/egalax_ts.c
-+++ b/drivers/input/touchscreen/egalax_ts.c
-@@ -57,6 +57,9 @@
-
- #define MAX_I2C_DATA_LEN 10
-
-+/* Enable single touch event mode */
-+#define FORCE_SINGLE_POINTER_SUPPORT 1
-+
- struct egalax_pointer {
- bool valid;
- bool status;
---
-1.7.4.1
-
diff --git a/recipes-kernel/linux/linux-imx_2.6.35.3.bb b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
index 7127d1a..99525b5 100644
--- a/recipes-kernel/linux/linux-imx_2.6.35.3.bb
+++ b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
@@ -1,18 +1,18 @@
# Copyright (C) 2011-2012 Freescale Semiconductor
# Released under the MIT license (see COPYING.MIT for the terms)
-PR = "${INC_PR}.9"
+PR = "${INC_PR}.10"
include linux-imx.inc
COMPATIBLE_MACHINE = "(mxs|mx5)"
# Revision of imx_2.6.35_10.12.01 branch
-SRCREV_mxs = "38bf41cc376e24c384934fbeb10770d6712e9143"
+SRCREV_mxs = "5910faa40398a445e6b76c2edd1793aa852f738a"
LOCALVERSION = "-10.12.01+yocto-${DATE}"
# Revision of imx_2.6.35_11.09.01 branch
-SRCREV_mx5 = "406cab2e8b3c030c0f86263282f846bb55a2faf6"
+SRCREV_mx5 = "7bd2ccd2539dba25eee4107122cbe0df70544d7f"
LOCALVERSION = "-11.09.01+yocto-${DATE}"
SRC_URI += "file://NFS-Fix-nfsroot-support.patch \
@@ -23,8 +23,3 @@ SRC_URI_append_mxs = " \
file://mx28-removecpufreq.patch \
file://mxs-duart-use-ttyAMA-for-device-name.patch \
"
-
-SRC_URI_append_mx5 = " \
- file://egalax_ts-enable-single-event-support.patch \
- file://0001-mx53_loco-add-USR-led-support.patch \
-"