aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/0002-cgroupfs-create-sys-fs-cgroup-to-mount-cgroupfs-on.patch58
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/smsc95xx-randomize-mac-once.patch51
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/w1-fix-support-multiple-master.patch79
-rw-r--r--recipes-kernel/linux/linux-imx-2.6.35.3/wire-up-sys_accept4-on-ARM.patch53
-rw-r--r--recipes-kernel/linux/linux-imx_2.6.35.3.bb12
5 files changed, 4 insertions, 249 deletions
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/0002-cgroupfs-create-sys-fs-cgroup-to-mount-cgroupfs-on.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/0002-cgroupfs-create-sys-fs-cgroup-to-mount-cgroupfs-on.patch
deleted file mode 100644
index 55ec975..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/0002-cgroupfs-create-sys-fs-cgroup-to-mount-cgroupfs-on.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-From 64bc6f1bfac43096d0102be252392f31405273ec Mon Sep 17 00:00:00 2001
-From: Greg KH <gregkh@suse.de>
-Date: Thu, 5 Aug 2010 13:53:35 -0700
-Subject: [PATCH 2/2] cgroupfs: create /sys/fs/cgroup to mount cgroupfs on
-
-We really shouldn't be asking userspace to create new root filesystems.
-So follow along with all of the other in-kernel filesystems, and provide
-a mount point in sysfs.
-
-For cgroupfs, this should be in /sys/fs/cgroup/ This change provides
-that mount point when the cgroup filesystem is registered in the kernel.
-
-Acked-by: Paul Menage <menage@google.com>
-Acked-by: Dhaval Giani <dhaval.giani@gmail.com>
-Cc: Li Zefan <lizf@cn.fujitsu.com>
-Cc: Lennart Poettering <lennart@poettering.net>
-Cc: Kay Sievers <kay.sievers@vrfy.org>
-Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>
----
- kernel/cgroup.c | 13 ++++++++++++-
- 1 files changed, 12 insertions(+), 1 deletions(-)
-
-diff --git a/kernel/cgroup.c b/kernel/cgroup.c
-index 7a14a97..cd81c18 100644
---- a/kernel/cgroup.c
-+++ b/kernel/cgroup.c
-@@ -1621,6 +1621,8 @@ static struct file_system_type cgroup_fs_type = {
- .kill_sb = cgroup_kill_sb,
- };
-
-+static struct kobject *cgroup_kobj;
-+
- static inline struct cgroup *__d_cgrp(struct dentry *dentry)
- {
- return dentry->d_fsdata;
-@@ -3885,9 +3887,18 @@ int __init cgroup_init(void)
- hhead = css_set_hash(init_css_set.subsys);
- hlist_add_head(&init_css_set.hlist, hhead);
- BUG_ON(!init_root_id(&rootnode));
-+
-+ cgroup_kobj = kobject_create_and_add("cgroup", fs_kobj);
-+ if (!cgroup_kobj) {
-+ err = -ENOMEM;
-+ goto out;
-+ }
-+
- err = register_filesystem(&cgroup_fs_type);
-- if (err < 0)
-+ if (err < 0) {
-+ kobject_put(cgroup_kobj);
- goto out;
-+ }
-
- proc_create("cgroups", 0, NULL, &proc_cgroupstats_operations);
-
---
-1.6.6.1
-
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/smsc95xx-randomize-mac-once.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/smsc95xx-randomize-mac-once.patch
deleted file mode 100644
index 18a5a7e..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/smsc95xx-randomize-mac-once.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-smsc95xx: generate random MAC address once, not every ifup
-
-The smsc95xx driver currently generates a new random MAC address
-every time the interface is brought up. This makes it impossible to
-override using the standard `ifconfig hw ether` approach.
-
-Past patches tried to make the MAC address a module parameter or
-base it off the die ID, but it seems to me much simpler (and
-hopefully less controversial) to stick with the current random
-generation scheme, but allow the user to change the address.
-
-This patch does exactly that - it moves the random address
-generation from smsc95xx_reset() into smsc95xx_bind(), so that it is
-done once on module load, not on every ifup. The user can then
-override this using the standard mechanisms.
-
-Applies against 2.6.35 and linux-2.6 head.
-
-Upstream-Status: Backport [2.6.36]
-
-Signed-off-by: Bernard Blackham <b-omap@largestprime.net>
-Signed-off-by: David S. Miller <davem@davemloft.net>
----
- drivers/net/usb/smsc95xx.c | 4 ++--
- 1 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/drivers/net/usb/smsc95xx.c b/drivers/net/usb/smsc95xx.c
-index 12a3c88..65cb1ab 100644
---- a/drivers/net/usb/smsc95xx.c
-+++ b/drivers/net/usb/smsc95xx.c
-@@ -805,8 +805,6 @@ static int smsc95xx_reset(struct usbnet *dev)
- return ret;
- }
-
-- smsc95xx_init_mac_address(dev);
--
- ret = smsc95xx_set_mac_address(dev);
- if (ret < 0)
- return ret;
-@@ -1047,6 +1045,8 @@ static int smsc95xx_bind(struct usbnet *dev, struct usb_interface *intf)
- pdata->use_tx_csum = DEFAULT_TX_CSUM_ENABLE;
- pdata->use_rx_csum = DEFAULT_RX_CSUM_ENABLE;
-
-+ smsc95xx_init_mac_address(dev);
-+
- /* Init all registers */
- ret = smsc95xx_reset(dev);
-
---
-1.7.7.6
-
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/w1-fix-support-multiple-master.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/w1-fix-support-multiple-master.patch
deleted file mode 100644
index 9ed730b..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/w1-fix-support-multiple-master.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-drivers/w1/w1_int.c: multiple masters used same init_name
-
-When using multiple masters, w1_int.c would use the .init_name from w1.c
-for all entities, which will fail when creating a corresponding sysfs
-entry. This patch uses the unique name previously generated.
-
- WARNING: at fs/sysfs/dir.c:451 sysfs_add_one+0x48/0x64()
- sysfs: cannot create duplicate filename '/devices/w1 bus master'
- Modules linked in:
- Call trace:
- [<9001a604>] warn_slowpath_common+0x34/0x44
- [<9001a64c>] warn_slowpath_fmt+0x14/0x18
- [<90078020>] sysfs_add_one+0x48/0x64
- [<900784ec>] create_dir+0x40/0x68
- [<9007857a>] sysfs_create_dir+0x66/0x78
- [<900c1a8a>] kobject_add_internal+0x6e/0x104
- [<900c1bc0>] kobject_add_varg+0x20/0x2c
- [<900c1c1c>] kobject_add+0x30/0x3c
- [<900dbd66>] device_add+0x6a/0x378
- [<900dbb4a>] device_initialize+0x12/0x48
- [<900dc080>] device_register+0xc/0x10
- [<900f99be>] w1_add_master_device+0x162/0x274
- [<90008e7a>] w1_gpio_probe+0x66/0xb4
- [<9000030c>] kernel_init+0x0/0xe8
- [<900dde54>] platform_drv_probe+0xc/0xe
- [<9000030c>] kernel_init+0x0/0xe8
- [<900dd4f8>] driver_probe_device+0x6c/0xdc
- [<900dd5fc>] __driver_attach+0x34/0x48
- [<900dcce8>] bus_for_each_dev+0x2c/0x48
- [<900dd5c8>] __driver_attach+0x0/0x48
- [<900dd38c>] driver_attach+0x10/0x14
- [<900dd16a>] bus_add_driver+0x6a/0x18c
- [<900dd768>] driver_register+0x60/0xb8
- [<90011594>] __initcall_w1_therm_init6+0x0/0x4
- [<90008e00>] w1_gpio_init+0x0/0x14
- [<9000030c>] kernel_init+0x0/0xe8
- [<900ddf48>] platform_driver_register+0x30/0x38
- [<90011594>] __initcall_w1_therm_init6+0x0/0x4
- [<90008e00>] w1_gpio_init+0x0/0x14
- [<9000030c>] kernel_init+0x0/0xe8
- [<900ddf5e>] platform_driver_probe+0xe/0x3c
- [<90008e0c>] w1_gpio_init+0xc/0x14
- [<90011594>] __initcall_w1_therm_init6+0x0/0x4
- [<90008e00>] w1_gpio_init+0x0/0x14
- [<900126d4>] do_one_initcall+0x34/0x130
- [<90000372>] kernel_init+0x66/0xe8
- [<90011594>] __initcall_w1_therm_init6+0x0/0x4
- [<9001ca3e>] do_exit+0x0/0x3a6
- [<9000030c>] kernel_init+0x0/0xe8
- [<9001ca3e>] do_exit+0x0/0x3a6
-
- ---[ end trace 5a9233884fead918 ]---
- kobject_add_internal failed for w1 bus master with -EEXIST, don't try to register things with the same name in the same directory.
-
-Upstream-Status: Backport [3.2]
-
-Signed-off-by: Florian Faber <faber@faberman.de>
-Cc: Evgeniy Polyakov <zbr@ioremap.net>
-Signed-off-by: Andrew Morton <akpm@linux-foundation.org>
-Signed-off-by: Linus Torvalds <torvalds@linux-foundation.org>
----
- drivers/w1/w1_int.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/drivers/w1/w1_int.c b/drivers/w1/w1_int.c
-index d220bce..f79e62e 100644
---- a/drivers/w1/w1_int.c
-+++ b/drivers/w1/w1_int.c
-@@ -78,6 +78,7 @@ static struct w1_master * w1_alloc_dev(u32 id, int slave_count, int slave_ttl,
- memcpy(&dev->dev, device, sizeof(struct device));
- dev_set_name(&dev->dev, "w1_bus_master%u", dev->id);
- snprintf(dev->name, sizeof(dev->name), "w1_bus_master%u", dev->id);
-+ dev->dev.init_name = dev->name;
-
- dev->driver = driver;
-
---
-1.7.10
-
diff --git a/recipes-kernel/linux/linux-imx-2.6.35.3/wire-up-sys_accept4-on-ARM.patch b/recipes-kernel/linux/linux-imx-2.6.35.3/wire-up-sys_accept4-on-ARM.patch
deleted file mode 100644
index 7182e80..0000000
--- a/recipes-kernel/linux/linux-imx-2.6.35.3/wire-up-sys_accept4-on-ARM.patch
+++ /dev/null
@@ -1,53 +0,0 @@
-From 1415ec63689ef39bcb24b5095941ec4cc884035c Mon Sep 17 00:00:00 2001
-From: Mikael Pettersson <mikpe@it.uu.se>
-Date: Sun, 15 Aug 2010 10:47:23 +0100
-Subject: [PATCH 1/2] ARM: 6329/1: wire up sys_accept4() on ARM
-
-sys_accept4() was added in kernel 2.6.28, but ARM was not updated
-to include it. The number and types of parameters is such that
-no ARM-specific processing is needed, so wiring up sys_accept4()
-just requires defining __NR_accept4 and adding a direct call in
-the syscall entry table.
-
-Tested with an EABI 2.6.35 kernel and Ulrich Drepper's original
-accept4() test program, modified to define __NR_accept4 for ARM.
-
-Using the updated unistd.h also eliminates a warning then building
-glibc (2.10.2 and newer) about accept4() being unimplemented.
-
-Upstream-Status: Backport [2.6.36]
-
-Signed-off-by: Mikael Pettersson <mikpe@it.uu.se>
-Signed-off-by: Russell King <rmk+kernel@arm.linux.org.uk>
----
- arch/arm/include/asm/unistd.h | 1 +
- arch/arm/kernel/calls.S | 1 +
- 2 files changed, 2 insertions(+), 0 deletions(-)
-
-diff --git a/arch/arm/include/asm/unistd.h b/arch/arm/include/asm/unistd.h
-index dd2bf53..d02cfb6 100644
---- a/arch/arm/include/asm/unistd.h
-+++ b/arch/arm/include/asm/unistd.h
-@@ -392,6 +392,7 @@
- #define __NR_rt_tgsigqueueinfo (__NR_SYSCALL_BASE+363)
- #define __NR_perf_event_open (__NR_SYSCALL_BASE+364)
- #define __NR_recvmmsg (__NR_SYSCALL_BASE+365)
-+#define __NR_accept4 (__NR_SYSCALL_BASE+366)
-
- /*
- * The following SWIs are ARM private.
-diff --git a/arch/arm/kernel/calls.S b/arch/arm/kernel/calls.S
-index 37ae301..afeb71f 100644
---- a/arch/arm/kernel/calls.S
-+++ b/arch/arm/kernel/calls.S
-@@ -375,6 +375,7 @@
- CALL(sys_rt_tgsigqueueinfo)
- CALL(sys_perf_event_open)
- /* 365 */ CALL(sys_recvmmsg)
-+ CALL(sys_accept4)
- #ifndef syscalls_counted
- .equ syscalls_padding, ((NR_syscalls + 3) & ~3) - NR_syscalls
- #define syscalls_counted
---
-1.6.6.1
-
diff --git a/recipes-kernel/linux/linux-imx_2.6.35.3.bb b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
index c487cbc..b63b6db 100644
--- a/recipes-kernel/linux/linux-imx_2.6.35.3.bb
+++ b/recipes-kernel/linux/linux-imx_2.6.35.3.bb
@@ -1,28 +1,24 @@
# Copyright (C) 2011-2012 Freescale Semiconductor
# Released under the MIT license (see COPYING.MIT for the terms)
-PR = "${INC_PR}.2"
+PR = "${INC_PR}.3"
include linux-imx.inc
COMPATIBLE_MACHINE = "(mxs|mx5)"
# Revision of imx_2.6.35_10.12.01 branch
-SRCREV_mxs = "a0e8d80376957175e959f70aba51a1cae487e414"
+SRCREV_mxs = "6a31a551bc302e74a17e9051bba356903e98273f"
LOCALVERSION = "-10.12.01+yocto-${DATE}"
# Revision of imx_2.6.35_11.09.01 branch
-SRCREV_mx5 = "3e2396eddb362ff70ee6eac43fb1f27f217dc0d1"
+SRCREV_mx5 = "cb0c4573ddf2eb4ee6942929f265560740f5dad2"
LOCALVERSION = "-11.09.01+yocto-${DATE}"
-SRC_URI += "file://0002-cgroupfs-create-sys-fs-cgroup-to-mount-cgroupfs-on.patch \
- file://NFS-Fix-nfsroot-support.patch \
+SRC_URI += "file://NFS-Fix-nfsroot-support.patch \
file://NFS-allow-nfs-root-mount-to-use-alternate-rpc-ports.patch \
file://no-unaligned-access.patch \
- file://w1-fix-support-multiple-master.patch \
- file://smsc95xx-randomize-mac-once.patch \
file://dm9601-support-for-usb-ethernet-0x0fe6-0x9700.patch \
- file://wire-up-sys_accept4-on-ARM.patch \
"
SRC_URI_append_mxs = " \