aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--recipes-kernel/linux/linux-imx/fix_getrusage_for_perf.patch33
-rw-r--r--recipes-kernel/linux/linux-imx_3.0.35.bb5
2 files changed, 37 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-imx/fix_getrusage_for_perf.patch b/recipes-kernel/linux/linux-imx/fix_getrusage_for_perf.patch
new file mode 100644
index 0000000..fb6a024
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx/fix_getrusage_for_perf.patch
@@ -0,0 +1,33 @@
+commit 7b78f13603c6fcb64e020a0bbe31a651ea2b657b
+Author: Markus Trippelsdorf <markus@trippelsdorf.de>
+Date: Wed Apr 4 10:45:27 2012 +0200
+
+ perf tools: Fix getrusage() related build failure on glibc trunk
+
+ On a system running glibc trunk perf doesn't build:
+
+ CC builtin-sched.o
+ builtin-sched.c: In function ‘get_cpu_usage_nsec_parent’: builtin-sched.c:399:16: error: storage size of ‘ru’ isn’t known builtin-sched.c:403:2: error: implicit declaration of function ‘getrusage’ [-Werror=implicit-function-declaration]
+ [...]
+
+ Fix it by including sys/resource.h.
+
+ Signed-off-by: Markus Trippelsdorf <markus@trippelsdorf.de>
+ Cc: Peter Zijlstra <a.p.zijlstra@chello.nl>
+ Link: http://lkml.kernel.org/r/20120404084527.GA294@x4
+ Signed-off-by: Ingo Molnar <mingo@kernel.org>
+
+Upstream-Status: Backport [3.4]
+
+diff --git a/tools/perf/builtin-sched.c b/tools/perf/builtin-sched.c
+index fb8b5f8..1cad3af 100644
+--- a/tools/perf/builtin-sched.c
++++ b/tools/perf/builtin-sched.c
+@@ -17,6 +17,7 @@
+ #include "util/debug.h"
+
+ #include <sys/prctl.h>
++#include <sys/resource.h>
+
+ #include <semaphore.h>
+ #include <pthread.h>
diff --git a/recipes-kernel/linux/linux-imx_3.0.35.bb b/recipes-kernel/linux/linux-imx_3.0.35.bb
index 4aa5f08..9c81bfd 100644
--- a/recipes-kernel/linux/linux-imx_3.0.35.bb
+++ b/recipes-kernel/linux/linux-imx_3.0.35.bb
@@ -3,7 +3,7 @@
include linux-imx.inc
-PR = "${INC_PR}.5"
+PR = "${INC_PR}.6"
COMPATIBLE_MACHINE = "(mx6)"
@@ -11,5 +11,8 @@ COMPATIBLE_MACHINE = "(mx6)"
SRCREV = "059685632ebd37a89e60cbb1e6dd535b3b08c3be"
LOCALVERSION = "-12.09.01+yocto"
+SRC_URI += "file://fix_getrusage_for_perf.patch \
+ "
+
# iMX6Q SabreLITE changes done by Boundary Devices
SRC_URI_append_imx6qsabrelite = " file://sync-boundary-changes.patch"