aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTom Hochstein <tom.hochstein@nxp.com>2016-09-13 19:53:19 -0500
committerOtavio Salvador <otavio@ossystems.com.br>2016-09-21 09:25:41 -0300
commitbe5669ecf813126c86b5ec206a4ab23f4dc15eee (patch)
tree2bb6d61c91e24289b6073fe1eba0f086f306d8e8
parentdc8bdf2027b66036198f6e1959a98759dfb9866b (diff)
downloadmeta-fsl-arm-be5669ecf813126c86b5ec206a4ab23f4dc15eee.tar.gz
meta-fsl-arm-be5669ecf813126c86b5ec206a4ab23f4dc15eee.tar.bz2
meta-fsl-arm-be5669ecf813126c86b5ec206a4ab23f4dc15eee.zip
gstreamer1.0-plugins-imx: Fix inoperable package configuration
All packages were being built all the time because the configure arguments from PACKAGECONFIG were not being passed. The problem manifested itself as the QA issue build-deps, but the problem wasn't fixed and the QA issue was silenced. This is fixed by passing the PACKAGECONFIG arguments through EXTRA_OECONF. Also, the build-deps QA issues are re-enabled. Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com> Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
-rw-r--r--recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.2.bb7
1 files changed, 1 insertions, 6 deletions
diff --git a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.2.bb b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.2.bb
index eb609bb..86c2b47 100644
--- a/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.2.bb
+++ b/recipes-multimedia/gstreamer/gstreamer1.0-plugins-imx_0.12.2.bb
@@ -32,7 +32,7 @@ EGLVIVSINK_PLATFORM = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', \
'fb', d),d)}"
EGL_PLATFORM_CONF = "--egl-platform=${EGLVIVSINK_PLATFORM}"
-EXTRA_OECONF = "--kernel-headers=${STAGING_KERNEL_DIR}/include"
+EXTRA_OECONF = "--kernel-headers=${STAGING_KERNEL_DIR}/include ${PACKAGECONFIG_CONFARGS}"
EGLVIVSINK_DEPENDS = " \
virtual/egl virtual/libgles2 \
@@ -64,8 +64,3 @@ require recipes-multimedia/gstreamer/gst-plugins-package.inc
PACKAGES_DYNAMIC = "^${PN}-.*"
COMPATIBLE_MACHINE = "(mx6|mx7)"
-
-# disable the false alarm (the "it isn't a build dependency" QA warning)
-INSANE_SKIP_gstreamer1.0-plugins-imx-imxaudio = "build-deps"
-INSANE_SKIP_gstreamer1.0-plugins-imx-imxvpu = "build-deps"
-INSANE_SKIP_gstreamer1.0-plugins-imx-imxg2d = "build-deps"