aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-virtualization/mux-server/mux-server_1.02.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-virtualization/mux-server/mux-server_1.02.bb')
-rw-r--r--recipes-virtualization/mux-server/mux-server_1.02.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes-virtualization/mux-server/mux-server_1.02.bb b/recipes-virtualization/mux-server/mux-server_1.02.bb
new file mode 100644
index 00000000..744a84c2
--- /dev/null
+++ b/recipes-virtualization/mux-server/mux-server_1.02.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A Linux-based utility supporting console multiplexing and demultiplexing"
+SECTION = "mux-server"
+LICENSE = "LGPL-2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
+
+SRC_URI = "git://git.freescale.com/ppc/sdk/hypervisor/mux_server.git;branch=master"
+SRCREV = "3e4c6a44a81bb5cf2996830e8034d26850f80efc"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE='HOSTCC="${CC}"'
+
+inherit deploy
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 755 mux_server ${D}${bindir}
+}
+
+do_deploy() {
+ install -d ${DEPLOYDIR}/hv
+ install -m 755 mux_server ${DEPLOYDIR}/hv/mux_server-${PKGV}-${PKGR}
+ ln -sf mux_server-${PKGV}-${PKGR} ${DEPLOYDIR}/hv/mux_server
+}
+addtask deploy after do_install
+
+BBCLASSEXTEND = "native nativesdk"