aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-virtualization/hv-cfg/hv-cfg_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-virtualization/hv-cfg/hv-cfg_git.bb')
-rw-r--r--recipes-virtualization/hv-cfg/hv-cfg_git.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/recipes-virtualization/hv-cfg/hv-cfg_git.bb b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
new file mode 100644
index 00000000..e4f18e07
--- /dev/null
+++ b/recipes-virtualization/hv-cfg/hv-cfg_git.bb
@@ -0,0 +1,52 @@
+DESCRIPTION = "Hypervisor Config"
+SECTION = "hv-cfg"
+LICENSE = "BSD"
+PR = "r6"
+
+LIC_FILES_CHKSUM = " \
+ file://p2041rdb/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
+ file://p3041ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
+ file://p4080ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
+ file://p5020ds/LICENSE;md5=96dd72f26e9bb861de5c76c60e35e1bc \
+"
+
+DEPENDS += "dtc-native"
+
+# this package is specific to the machine itself
+INHIBIT_DEFAULT_DEPS = "1"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit deploy
+
+SRC_URI = "git://git.freescale.com/ppc/sdk/hv-cfg.git;nobranch=1"
+SRCREV = "b9287b07390d17bfba936a806a72b91b89507c22"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ make install
+
+ M=`echo ${MACHINE} | sed s/-64b//g`
+ if [ "t1042d4rdb" = "${M}" ] || [ "t1040d4rdb" = "${M}" ];then
+ M=t1040rdb
+ fi
+ install -d ${D}/boot/hv-cfg
+ cp -r ${S}/${M}/${M}/* ${D}/boot/hv-cfg
+}
+
+do_deploy () {
+ M=`echo ${MACHINE} | sed s/-64b//g`
+ if [ "t1042d4rdb" = "${M}" ] || [ "t1040d4rdb" = "${M}" ];then
+ M=t1040rdb
+ fi
+ install -d ${DEPLOYDIR}/hv-cfg
+ cp -r ${S}/${M}/${M}/* ${DEPLOYDIR}/hv-cfg
+}
+addtask deploy after do_install
+
+PACKAGES += "${PN}-image"
+FILES_${PN}-image += "/boot"
+
+COMPATIBLE_HOST_qoriq-ppc = ".*"
+COMPATIBLE_HOST ?= "(none)"
+ALLOW_EMPTY_${PN} = "1"