aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.3.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.3.5.bb')
-rw-r--r--recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.3.5.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.3.5.bb b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.3.5.bb
new file mode 100644
index 00000000..2d4bdf68
--- /dev/null
+++ b/recipes-multimedia/imx-vpuwrap/imx-vpuwrap_4.3.5.bb
@@ -0,0 +1,32 @@
+# Copyright (C) 2013-2016 Freescale Semiconductor
+# Copyright 2017 NXP
+# Copyright 2018 (C) O.S. Systems Software LTDA.
+# Released under the MIT license (see COPYING.MIT for the terms)
+DESCRIPTION = "Freescale Multimedia VPU wrapper"
+DEPENDS = "virtual/imxvpu"
+LICENSE = "Proprietary"
+SECTION = "multimedia"
+LIC_FILES_CHKSUM = "file://COPYING;md5=75abe2fa1d16ca79f87cde926f05f72d"
+
+# For backwards compatibility
+PROVIDES += "libfslvpuwrap"
+RREPLACES_${PN} = "libfslvpuwrap"
+RPROVIDES_${PN} = "libfslvpuwrap"
+RCONFLICTS_${PN} = "libfslvpuwrap"
+
+SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
+
+SRC_URI[md5sum] = "ebcafcd76ec7c5b7cb9ba084da2b5612"
+SRC_URI[sha256sum] = "5c08b4b7c771404c998779f0e27a75564b57958d463e2df152c910d76cca9e44"
+
+inherit fsl-eula-unpack autotools pkgconfig
+
+do_install_append() {
+ # FIXME: Drop examples for now
+ rm -r ${D}${datadir}
+}
+
+INSANE_SKIP_imx-vpuwrap = "file-rdeps"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "(mx6q|mx6dl)"