aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.9.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.9.bb b/recipes-kernel/linux/linux-qoriq_4.9.bb
index 3e058c21..84888e05 100644
--- a/recipes-kernel/linux/linux-qoriq_4.9.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.9.bb
@@ -14,7 +14,7 @@ S = "${WORKDIR}/git"
DEPENDS_append = " libgcc"
# not put Images into /boot of rootfs, install kernel-image if needed
-RDEPENDS_kernel-base = ""
+RDEPENDS_${KERNEL_PACKAGE_NAME}-base = ""
KERNEL_CC_append = " ${TOOLCHAIN_OPTIONS}"
KERNEL_LD_append = " ${TOOLCHAIN_OPTIONS}"
@@ -60,5 +60,5 @@ do_install_append_qoriq-arm() {
ln -sf zImage-${KERNEL_VERSION} ${D}/boot/zImage
}
-FILES_kernel-image += "/boot/zImage*"
+FILES_${KERNEL_PACKAGE_NAME}-image += "/boot/zImage*"
COMPATIBLE_MACHINE = "(qoriq)"