aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-qoriq_4.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-qoriq_4.9.bb')
-rw-r--r--recipes-kernel/linux/linux-qoriq_4.9.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/recipes-kernel/linux/linux-qoriq_4.9.bb b/recipes-kernel/linux/linux-qoriq_4.9.bb
index 7229b014..f6d29429 100644
--- a/recipes-kernel/linux/linux-qoriq_4.9.bb
+++ b/recipes-kernel/linux/linux-qoriq_4.9.bb
@@ -1,4 +1,4 @@
-inherit kernel qoriq_build_64bit_kernel
+inherit kernel qoriq_build_64bit_kernel siteinfo
inherit fsl-kernel-localversion
SUMMARY = "Linux Kernel for Freescale QorIQ platforms"
@@ -36,6 +36,12 @@ do_merge_delta_config() {
# create .config with make config
oe_runmake -C ${S} O=${B} ${KERNEL_DEFCONFIG}
+ # check if bigendian is enabled
+ if [ "${SITEINFO_ENDIANNESS}" = "be" ]; then
+ echo "CONFIG_CPU_BIG_ENDIAN=y" >> .config
+ echo "CONFIG_MTD_CFI_BE_BYTE_SWAP=y" >> .config
+ fi
+
# add config fragments
for deltacfg in ${DELTA_KERNEL_DEFCONFIG}; do
if [ -f ${S}/arch/${ARCH}/configs/${deltacfg} ]; then