aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/linux/linux-imx-mfgtool_4.9.88.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/linux/linux-imx-mfgtool_4.9.88.bb')
-rw-r--r--recipes-kernel/linux/linux-imx-mfgtool_4.9.88.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes-kernel/linux/linux-imx-mfgtool_4.9.88.bb b/recipes-kernel/linux/linux-imx-mfgtool_4.9.88.bb
new file mode 100644
index 00000000..7ffd3c7a
--- /dev/null
+++ b/recipes-kernel/linux/linux-imx-mfgtool_4.9.88.bb
@@ -0,0 +1,18 @@
+# Copyright (C) 2014-2018 O.S. Systems Software LTDA.
+# Copyright (C) 2014-2016 Freescale Semiconductor
+
+SUMMARY = "Produces a Manufacturing Tool compatible Linux Kernel"
+DESCRIPTION = "Linux Kernel provided and supported by Freescale that produces a \
+Manufacturing Tool compatible Linux Kernel to be used in updater environment"
+
+require linux-imx_${PV}.bb
+require linux-mfgtool.inc
+
+KERNEL_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
+MODULE_IMAGE_BASE_NAME[vardepsexclude] = "DATETIME"
+do_package[vardepsexclude] = "DATETIME"
+
+do_deploy () {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install arch/arm/boot/zImage ${DEPLOY_DIR_IMAGE}/zImage_mfgtool
+}