aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-kernel/cryptodev/cryptodev-linux_1.7.bb')
-rw-r--r--recipes-kernel/cryptodev/cryptodev-linux_1.7.bb12
1 files changed, 12 insertions, 0 deletions
diff --git a/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb b/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb
new file mode 100644
index 00000000..92ccd717
--- /dev/null
+++ b/recipes-kernel/cryptodev/cryptodev-linux_1.7.bb
@@ -0,0 +1,12 @@
+require cryptodev_${PV}.inc
+
+SUMMARY = "A /dev/crypto device driver header file"
+
+do_compile[noexec] = "1"
+
+# Just install cryptodev.h which is the only header file needed to be exported
+do_install() {
+ install -D ${S}/crypto/cryptodev.h ${D}${includedir}/crypto/cryptodev.h
+}
+
+ALLOW_EMPTY_${PN} = "1"