aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/wayland/weston/imx/weston.ini20
-rw-r--r--recipes-graphics/wayland/weston_4.0.0.imx.bb4
2 files changed, 22 insertions, 2 deletions
diff --git a/recipes-graphics/wayland/weston/imx/weston.ini b/recipes-graphics/wayland/weston/imx/weston.ini
new file mode 100644
index 00000000..d6ad40df
--- /dev/null
+++ b/recipes-graphics/wayland/weston/imx/weston.ini
@@ -0,0 +1,20 @@
+[core]
+# i.MX: Disable idle timeout
+idle-time=0
+
+#[output]
+#name=HDMI-A-1
+#mode=1920x1080@60
+#transform=90
+
+#[output]
+#name=HDMI-A-2
+#mode=off
+# WIDTHxHEIGHT Resolution size width and height in pixels
+# off Disables the output
+# preferred Uses the preferred mode
+# current Uses the current crt controller mode
+#transform=90
+
+[screen-share]
+command=/usr/bin/weston --backend=rdp-backend.so --shell=fullscreen-shell.so --no-clients-resize
diff --git a/recipes-graphics/wayland/weston_4.0.0.imx.bb b/recipes-graphics/wayland/weston_4.0.0.imx.bb
index e80e7e0a..1a31016a 100644
--- a/recipes-graphics/wayland/weston_4.0.0.imx.bb
+++ b/recipes-graphics/wayland/weston_4.0.0.imx.bb
@@ -9,6 +9,7 @@ DEFAULT_PREFERENCE = "-1"
SRCBRANCH = "weston-imx-4.0"
SRC_URI = "git://source.codeaurora.org/external/imx/weston-imx.git;protocol=https;branch=${SRCBRANCH} \
+ file://weston.ini \
file://weston.png \
file://weston.desktop \
file://0001-make-error-portable.patch \
@@ -111,8 +112,7 @@ do_install_append() {
fi
# install default weston.ini
- install -d ${D}${sysconfdir}/xdg/weston
- install -m 0644 ${B}/weston.ini ${D}${sysconfdir}/xdg/weston
+ install -D -m 0644 ${WORKDIR}/weston.ini ${D}${sysconfdir}/xdg/weston/weston.ini
}
PACKAGES += "${@bb.utils.contains('PACKAGECONFIG', 'xwayland', '${PN}-xwayland', '', d)} \