aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics')
-rw-r--r--recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.6.bb38
-rw-r--r--recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.8.bb41
2 files changed, 41 insertions, 38 deletions
diff --git a/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.6.bb b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.6.bb
deleted file mode 100644
index 85268817..00000000
--- a/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.6.bb
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright (C) 2016 Freescale Semiconductor
-# Copyright 2017-2018 NXP
-# Copyright 2018 (C) O.S. Systems Software LTDA.
-# Released under the MIT license (see COPYING.MIT for the terms)
-
-DESCRIPTION = "G2D graphics library and apps for i.MX 6 and i.MX 7 GPU"
-LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://COPYING;md5=ab61cab9599935bfe9f700405ef00f28"
-
-DEPENDS += "libgal-imx"
-PROVIDES += "virtual/libg2d"
-
-SRC_URI = "${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true"
-
-S="${WORKDIR}/${PN}-${PV}"
-
-inherit fsl-eula-unpack
-
-SRC_URI[md5sum] = "0829288a9b4fcc89066d1671aeb671b9"
-SRC_URI[sha256sum] = "5ded476226df9068ec8611b5e89d444de1e5d9a53374a7ea4fb47bc5c6ba20e0"
-
-do_install () {
-
- install -d ${D}${libdir}
- install -d ${D}${includedir}
-
- cp ${S}/g2d/usr/lib/*.so* ${D}${libdir}
- cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
- cp -r ${S}/gpu-demos/opt ${D}
-}
-
-RDEPENDS_${PN} = "libgal-imx"
-
-FILES_${PN} = "${libdir}/libg2d* /opt"
-FILES_${PN}-dev = "${includedir}"
-INSANE_SKIP_${PN} = "ldflags"
-
-COMPATIBLE_MACHINE = "(imxgpu2d)"
diff --git a/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.8.bb b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.8.bb
new file mode 100644
index 00000000..ab712377
--- /dev/null
+++ b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p1.8.bb
@@ -0,0 +1,41 @@
+# Copyright (C) 2016 Freescale Semiconductor
+# Copyright 2017-2018 NXP
+# Copyright 2018 (C) O.S. Systems Software LTDA.
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and no DPU"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db"
+
+DEPENDS += "libgal-imx"
+PROVIDES += "virtual/libg2d"
+
+# FIXME: arm packages are mis-labeled with aarch32 suffix
+FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}"
+FSLBIN_NAME_arm = "${PN}-${PV}-aarch32"
+
+SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true"
+SRC_URI[arm.md5sum] = "ab7e43c997d3a84764fc3cc72d3b397c"
+SRC_URI[arm.sha256sum] = "88b3af3dd109e7c9c457d19441dbb668e7c395d29340d724db3cc42dc04ae87b"
+SRC_URI[aarch64.md5sum] = "287f2de4bd407b2eb484d332ae6de157"
+SRC_URI[aarch64.sha256sum] = "77f191135f2be6052eabc8cca50b4ea7b5eaec015488cc108fb3f9656a3a1367"
+
+S = "${WORKDIR}/${FSLBIN_NAME}"
+
+inherit fsl-eula-unpack
+
+do_install () {
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+ cp ${S}/g2d/usr/lib/*.so* ${D}${libdir}
+ cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
+ cp -r ${S}/gpu-demos/opt ${D}
+}
+
+FILES_${PN} = "${libdir}/libg2d* /opt"
+FILES_${PN}-dev = "${includedir}"
+INSANE_SKIP_${PN} = "ldflags"
+
+RDEPENDS_${PN} = "libgal-imx"
+
+COMPATIBLE_MACHINE = "(imxgpu2d)"