aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p4.0.bb')
-rw-r--r--recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p4.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p4.0.bb b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p4.0.bb
new file mode 100644
index 00000000..1329f365
--- /dev/null
+++ b/recipes-graphics/imx-gpu-g2d/imx-gpu-g2d_6.2.4.p4.0.bb
@@ -0,0 +1,39 @@
+# Copyright (C) 2016 Freescale Semiconductor
+# Copyright 2017-2018 NXP
+# Copyright 2018 (C) O.S. Systems Software LTDA.
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+DESCRIPTION = "GPU G2D library and apps for i.MX with 2D GPU and no DPU"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM = "file://COPYING;md5=80c0478f4339af024519b3723023fe28"
+
+DEPENDS += "libgal-imx"
+PROVIDES += "virtual/libg2d"
+
+FSLBIN_NAME = "${PN}-${PV}-${TARGET_ARCH}"
+
+SRC_URI = "${FSL_MIRROR}/${FSLBIN_NAME}.bin;name=${TARGET_ARCH};fsl-eula=true"
+SRC_URI[aarch64.md5sum] = "ec8d8662ac31b96122a1af7736831482"
+SRC_URI[aarch64.sha256sum] = "362265b9c6c6ce05b1fafb412efe6617cf142669eb21302beec5e87ebbfe6a25"
+SRC_URI[arm.md5sum] = "bb1ef2e365b5d72e2a03c3b39d2016cc"
+SRC_URI[arm.sha256sum] = "27557094f4b5e7bef87c73131959503f3d0c3a6ea1c4f010d86c1668078f7f22"
+
+S = "${WORKDIR}/${FSLBIN_NAME}"
+
+inherit fsl-eula-unpack
+
+do_install () {
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+ cp ${S}/g2d/usr/lib/*.so* ${D}${libdir}
+ cp -Pr ${S}/g2d/usr/include/* ${D}${includedir}
+ cp -r ${S}/gpu-demos/opt ${D}
+}
+
+FILES_${PN} = "${libdir}/libg2d* /opt"
+FILES_${PN}-dev = "${includedir}"
+INSANE_SKIP_${PN} = "ldflags"
+
+RDEPENDS_${PN} = "libgal-imx"
+
+COMPATIBLE_MACHINE = "(imxgpu2d)"