aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-fsl
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-fsl')
-rw-r--r--recipes-fsl/mcore-demos/README14
-rw-r--r--recipes-fsl/mcore-demos/imx-m33-demos_2.14.1.bb11
-rw-r--r--recipes-fsl/mcore-demos/imx-m33-demos_2.15.000.bb11
-rw-r--r--recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb28
-rw-r--r--recipes-fsl/mcore-demos/imx-m4-demos_2.14.0.bb15
-rw-r--r--recipes-fsl/mcore-demos/imx-m4-demos_2.14.1.bb11
-rw-r--r--recipes-fsl/mcore-demos/imx-m4-demos_2.9.0.bb19
-rw-r--r--recipes-fsl/mcore-demos/imx-m7-demos_2.14.0.bb15
-rw-r--r--recipes-fsl/mcore-demos/imx-m7-demos_2.14.1.bb12
-rw-r--r--recipes-fsl/mcore-demos/imx-m7-demos_2.15.000.bb11
-rw-r--r--recipes-fsl/mcore-demos/imx-mcore-demos.inc63
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-isp.bb6
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb8
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-opencv-imx.bb2
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-qca6174.bb13
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-qca9377.bb12
16 files changed, 219 insertions, 32 deletions
diff --git a/recipes-fsl/mcore-demos/README b/recipes-fsl/mcore-demos/README
new file mode 100644
index 00000000..f38e8a6e
--- /dev/null
+++ b/recipes-fsl/mcore-demos/README
@@ -0,0 +1,14 @@
+The M4 demo app version of each SoCs are followed:
+* 2.14.0 -- i.MX 7ULP, 8MQ
+* 2.14.1 -- i.MX 8MM
+* 2.9.0 -- i.MX 8DXL, 8QM, 8QXP
+* 1.0.1 -- i.MX 7D
+
+The M7 demo app version of each SoCs are followed:
+* 2.14.0 -- i.MX 8MNULite, 8MN
+* 2.14.1 -- i.MX 8MP
+* 2.15.000 -- i.MX95
+
+The M33 demo app version of each SoCs are followed:
+* 2.14.1 -- i.MX 8ULP
+* 2.15.000 -- i.MX 93
diff --git a/recipes-fsl/mcore-demos/imx-m33-demos_2.14.1.bb b/recipes-fsl/mcore-demos/imx-m33-demos_2.14.1.bb
new file mode 100644
index 00000000..0107d90e
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m33-demos_2.14.1.bb
@@ -0,0 +1,11 @@
+# Copyright 2023 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require imx-mcore-demos.inc
+
+LIC_FILES_CHKSUM:mx8ulp-nxp-bsp = "file://COPYING;md5=db4762b09b6bda63da103963e6e081de"
+
+SRC_URI[imx8ulp.md5sum] = "6a1d2b904255ad2b514a234e6282209f"
+SRC_URI[imx8ulp.sha256sum] = "eb8710c31dd58e23ed50653a1b90106e78776a1062abea2a16139cf371828a5a"
+
+COMPATIBLE_MACHINE = "(mx8ulp-nxp-bsp)"
diff --git a/recipes-fsl/mcore-demos/imx-m33-demos_2.15.000.bb b/recipes-fsl/mcore-demos/imx-m33-demos_2.15.000.bb
new file mode 100644
index 00000000..542ff168
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m33-demos_2.15.000.bb
@@ -0,0 +1,11 @@
+# Copyright 2023 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require imx-mcore-demos.inc
+
+LIC_FILES_CHKSUM:mx93-nxp-bsp = "file://COPYING;md5=44a8052c384584ba09077e85a3d1654f"
+
+SRC_URI[imx93.md5sum] = "2fad663ff63d273a2cb775e06db9eedc"
+SRC_URI[imx93.sha256sum] = "257066cbd57add127fae15da72f12f1cf6a847ff300e7b4ac63f507693898dfa"
+
+COMPATIBLE_MACHINE = "(mx93-nxp-bsp)"
diff --git a/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb b/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb
new file mode 100644
index 00000000..fd99c637
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m4-demos_1.0.1.bb
@@ -0,0 +1,28 @@
+SUMMARY = "i.MX M4 core Demo images"
+SECTION = "app"
+LICENSE = "Proprietary"
+LIC_FILES_CHKSUM:mx7d-nxp-bsp = "file://COPYING;md5=8cf95184c220e247b9917e7244124c5a"
+
+inherit deploy fsl-eula-unpack
+
+M4_SOC ?= "INVALID"
+M4_SOC:mx7d-nxp-bsp = "imx7d-sabresd"
+
+SRC_URI = "${FSL_MIRROR}/${M4_SOC}-m4-freertos-${PV}.bin;fsl-eula=true"
+S = "${WORKDIR}/${M4_SOC}-m4-freertos-${PV}"
+
+SRC_URI[md5sum] = "b05b780ff3916f4953ab58ac95233c38"
+SRC_URI[sha256sum] = "cc00d3b936d49b2794a2a99e10129437e70caba3fd26b8379b8c50dd22f73254"
+
+do_deploy () {
+ # Install the demo binaries
+ install -d ${DEPLOYDIR}
+ cp ${S}/*.bin ${DEPLOYDIR}/
+ ls ${DEPLOYDIR}/
+}
+
+addtask deploy before do_build after do_compile
+
+PACKAGE_ARCH = "${MACHINE_SOCARCH}"
+COMPATIBLE_MACHINE = "(mx7d-nxp-bsp)"
+
diff --git a/recipes-fsl/mcore-demos/imx-m4-demos_2.14.0.bb b/recipes-fsl/mcore-demos/imx-m4-demos_2.14.0.bb
new file mode 100644
index 00000000..b2076cca
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m4-demos_2.14.0.bb
@@ -0,0 +1,15 @@
+# Copyright 2017-2023 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require imx-mcore-demos.inc
+
+LIC_FILES_CHKSUM:mx8mq-nxp-bsp = "file://COPYING;md5=9135422c7a38dac21bf1f858b6ef3bac"
+LIC_FILES_CHKSUM:mx7ulp-nxp-bsp = "file://COPYING;md5=9135422c7a38dac21bf1f858b6ef3bac"
+
+SRC_URI[imx8mq.md5sum] = "0235860aca583e50af88b141e8f25d13"
+SRC_URI[imx8mq.sha256sum] = "decb52b246800e3fa926704207a0ac9a960723da8502887a31f353aaa370c9d9"
+
+SRC_URI[imx7ulp.md5sum] = "4ec757b7a2a2bdf33f583c328a4631f1"
+SRC_URI[imx7ulp.sha256sum] = "51715bee5e300ee6160c92979e7075e3aa7f7114e7742699bfaa9779113a6fe9"
+
+COMPATIBLE_MACHINE = "(mx7ulp-nxp-bsp|mx8mq-nxp-bsp)"
diff --git a/recipes-fsl/mcore-demos/imx-m4-demos_2.14.1.bb b/recipes-fsl/mcore-demos/imx-m4-demos_2.14.1.bb
new file mode 100644
index 00000000..67fadb2f
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m4-demos_2.14.1.bb
@@ -0,0 +1,11 @@
+# Copyright 2017-2023 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require imx-mcore-demos.inc
+
+LIC_FILES_CHKSUM:mx8mm-nxp-bsp = "file://COPYING;md5=db4762b09b6bda63da103963e6e081de"
+
+SRC_URI[imx8mm.md5sum] = "8db99da9efe8a5409a246c8a63d418dc"
+SRC_URI[imx8mm.sha256sum] = "8269d7461efcdba0b8c3e684df8b45c2d8ace3fdf426b81bdfb46855a1577987"
+
+COMPATIBLE_MACHINE = "(mx8mm-nxp-bsp)"
diff --git a/recipes-fsl/mcore-demos/imx-m4-demos_2.9.0.bb b/recipes-fsl/mcore-demos/imx-m4-demos_2.9.0.bb
new file mode 100644
index 00000000..63c402dd
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m4-demos_2.9.0.bb
@@ -0,0 +1,19 @@
+# Copyright 2017-2021 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require imx-mcore-demos.inc
+
+LIC_FILES_CHKSUM:mx8dxl-nxp-bsp = "file://COPYING;md5=cf3f9b8d09bc3926b1004ea71f7a248a"
+LIC_FILES_CHKSUM:mx8qm-nxp-bsp = "file://COPYING;md5=a632fefd1c359980434f9389833cab3a"
+LIC_FILES_CHKSUM:mx8qxp-nxp-bsp = "file://COPYING;md5=a632fefd1c359980434f9389833cab3a"
+
+SRC_URI[imx8dxl.md5sum] = "8850c04a8af91e2bd822cecd5ec56e12"
+SRC_URI[imx8dxl.sha256sum] = "66ddba970712ed394de4034b362334a12caa5865a6afc1dfb5a897bb55b4fcf1"
+
+SRC_URI[imx8qm.md5sum] = "5912ca94847ee56a7e8b866b211b67d9"
+SRC_URI[imx8qm.sha256sum] = "c695e72b0c7f609132f5990469cf950c03e137de887bd7e24d059c51a7b499be"
+
+SRC_URI[imx8qx.md5sum] = "5bc15014f59b2b11c71299fac608be5d"
+SRC_URI[imx8qx.sha256sum] = "bbb268a30a58a86e38966122191c8aa69f427c6c1d56b0ce81e518f4d652782a"
+
+COMPATIBLE_MACHINE = "(mx8dxl-nxp-bsp|mx8qm-nxp-bsp|mx8qxp-nxp-bsp|mx8dx-nxp-bsp)"
diff --git a/recipes-fsl/mcore-demos/imx-m7-demos_2.14.0.bb b/recipes-fsl/mcore-demos/imx-m7-demos_2.14.0.bb
new file mode 100644
index 00000000..7849ccca
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m7-demos_2.14.0.bb
@@ -0,0 +1,15 @@
+# Copyright 2019-2023 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require imx-mcore-demos.inc
+
+LIC_FILES_CHKSUM:mx8mn-nxp-bsp = "file://COPYING;md5=9135422c7a38dac21bf1f858b6ef3bac"
+LIC_FILES_CHKSUM:mx8mnul-nxp-bsp = "file://COPYING;md5=9135422c7a38dac21bf1f858b6ef3bac"
+
+SRC_URI[imx8mn.md5sum] = "5ba15434b72f1eb7315e6ddb8a66a0f9"
+SRC_URI[imx8mn.sha256sum] = "8fe6c76da7eb0bbebb8e18a308249ca78a1c5c1d58034cf0fd3c5028aa5740e2"
+
+SRC_URI[imx8mnddr3l.md5sum] = "62115bc3415eac0f9a4249ed9bb94f98"
+SRC_URI[imx8mnddr3l.sha256sum] = "4b405e1ae439f651c21c4d4bd88f89695974a15aabb89cba65daa2f9922b273d"
+
+COMPATIBLE_MACHINE = "(mx8mn-nxp-bsp|mx8mnul-nxp-bsp)"
diff --git a/recipes-fsl/mcore-demos/imx-m7-demos_2.14.1.bb b/recipes-fsl/mcore-demos/imx-m7-demos_2.14.1.bb
new file mode 100644
index 00000000..ddd99661
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m7-demos_2.14.1.bb
@@ -0,0 +1,12 @@
+# Copyright 2023 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require imx-mcore-demos.inc
+
+LIC_FILES_CHKSUM:mx8mp-nxp-bsp = "file://COPYING;md5=db4762b09b6bda63da103963e6e081de"
+LIC_FILES_CHKSUM:mx8mpul-nxp-bsp = "file://COPYING;md5=db4762b09b6bda63da103963e6e081de"
+
+SRC_URI[imx8mp.md5sum] = "f12cd36cd48cfc65ada700445f8cecaf"
+SRC_URI[imx8mp.sha256sum] = "f2da9e7d7ea6d7b5f33eb12d20e6c5c07fe3110d362f5263d672729f2cd73b37"
+
+COMPATIBLE_MACHINE = "(mx8mp-nxp-bsp|mx8mpul-nxp-bsp)"
diff --git a/recipes-fsl/mcore-demos/imx-m7-demos_2.15.000.bb b/recipes-fsl/mcore-demos/imx-m7-demos_2.15.000.bb
new file mode 100644
index 00000000..07794205
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-m7-demos_2.15.000.bb
@@ -0,0 +1,11 @@
+# Copyright 2023 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require imx-mcore-demos.inc
+
+LIC_FILES_CHKSUM:mx95-nxp-bsp = "file://COPYING;md5=44a8052c384584ba09077e85a3d1654f"
+
+SRC_URI[imx95.md5sum] = "572b54c7255faa020612261462bdd96b"
+SRC_URI[imx95.sha256sum] = "118ea2248d7fd8a48412855fc19ff6f37f4e09e6d387dfdd458bb9a19d6192c6"
+
+COMPATIBLE_MACHINE = "(mx95-nxp-bsp)"
diff --git a/recipes-fsl/mcore-demos/imx-mcore-demos.inc b/recipes-fsl/mcore-demos/imx-mcore-demos.inc
new file mode 100644
index 00000000..32afc312
--- /dev/null
+++ b/recipes-fsl/mcore-demos/imx-mcore-demos.inc
@@ -0,0 +1,63 @@
+# Copyright 2017-2021 NXP
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+SUMMARY = "i.MX M4/M7/M33 core Demo images"
+SECTION = "app"
+LICENSE = "Proprietary"
+
+inherit deploy fsl-eula-unpack
+
+SOC ?= "INVALID"
+SOC:mx7ulp-nxp-bsp = "imx7ulp"
+SOC:mx8dxl-nxp-bsp = "imx8dxl"
+SOC:mx8mm-nxp-bsp = "imx8mm"
+SOC:mx8mn-nxp-bsp = "imx8mn"
+SOC:mx8mnul-nxp-bsp = "imx8mnddr3l"
+SOC:mx8mp-nxp-bsp = "imx8mp"
+SOC:mx8mpul-nxp-bsp = "imx8mp"
+SOC:mx8mq-nxp-bsp = "imx8mq"
+SOC:mx8qm-nxp-bsp = "imx8qm"
+SOC:mx8qxp-nxp-bsp = "imx8qx"
+SOC:mx8dx-nxp-bsp = "imx8qx"
+SOC:mx8ulp-nxp-bsp = "imx8ulp"
+SOC:mx93-nxp-bsp = "imx93"
+SOC:mx95-nxp-bsp = "imx95"
+
+MCORE_TYPE ?= "m4"
+MCORE_TYPE:mx8mn-nxp-bsp = "m7"
+MCORE_TYPE:mx8mnul-nxp-bsp = "m7"
+MCORE_TYPE:mx8mp-nxp-bsp = "m7"
+MCORE_TYPE:mx8mpul-nxp-bsp = "m7"
+MCORE_TYPE:mx8ulp-nxp-bsp = "m33"
+MCORE_TYPE:mx93-nxp-bsp = "m33"
+MCORE_TYPE:mx95-nxp-bsp = "m7"
+
+SRC_URI = "${FSL_MIRROR}/${SOC}-${MCORE_TYPE}-demo-${PV}.bin;name=${SOC};fsl-eula=true"
+
+S = "${WORKDIR}/${SOC}-${MCORE_TYPE}-demo-${PV}"
+
+#SRC_URI="https://www.nxp.com/lgfiles/NMG/MAD/YOCTO//imx93-m33-demo-2.14.0.bin;fsl-eula=true;name=imx93"
+
+
+SCR = "SCR-${SOC}-${MCORE_TYPE}-demo.txt"
+
+do_install () {
+ install -d ${D}${nonarch_base_libdir}/firmware
+ install -m 0644 ${S}/*.elf ${D}${nonarch_base_libdir}/firmware
+}
+
+DEPLOY_FILE_EXT ?= "bin"
+DEPLOY_FILE_EXT:mx7ulp-nxp-bsp = "img"
+
+do_deploy () {
+ # Install the demo binaries
+ install -m 0644 ${S}/*.${DEPLOY_FILE_EXT} ${DEPLOYDIR}/
+}
+
+addtask deploy after do_install
+
+PACKAGE_ARCH = "${MACHINE_SOCARCH}"
+
+FILES:${PN} = "${nonarch_base_libdir}/firmware"
+
+INSANE_SKIP:${PN} = "arch"
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-isp.bb b/recipes-fsl/packagegroups/packagegroup-fsl-isp.bb
index 4ad257ee..415587a8 100644
--- a/recipes-fsl/packagegroups/packagegroup-fsl-isp.bb
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-isp.bb
@@ -1,14 +1,16 @@
DESCRIPTION = "Add packages for ISP build"
+# basler-camera* gets dynamically renamed
+PACKAGE_ARCH = "${MACHINE_ARCH}"
inherit packagegroup
ISP_PKGS ?= ""
-ISP_PKGS_mx8mp = " \
+ISP_PKGS:mx8mp-nxp-bsp = " \
isp-imx \
basler-camera \
basler-camera-dev \
kernel-module-isp-vvcam \
"
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
${ISP_PKGS} \
"
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
index 968642bf..d0367fdb 100644
--- a/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
@@ -20,7 +20,7 @@ MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
# Distro can override the following VIRTUAL-RUNTIME providers:
VIRTUAL-RUNTIME_keymaps ?= "keymaps"
-RDEPENDS_${PN}-base = " \
+RDEPENDS:${PN}-base = " \
bash \
imx-uuc \
util-linux \
@@ -34,16 +34,16 @@ RDEPENDS_${PN}-base = " \
${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
"
-RDEPENDS_${PN}-mtd = " \
+RDEPENDS:${PN}-mtd = " \
${PN}-base \
imx-kobs \
mtd-utils \
mtd-utils-ubifs \
"
-RDEPENDS_${PN}-extfs = " \
+RDEPENDS:${PN}-extfs = " \
${PN}-base \
e2fsprogs-mke2fs \
e2fsprogs-e2fsck \
"
-COMPATIBLE_MACHINE = "(imx|use-mainline-bsp)"
+COMPATIBLE_MACHINE = "(imx-generic-bsp)"
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-opencv-imx.bb b/recipes-fsl/packagegroups/packagegroup-fsl-opencv-imx.bb
index 8eb5b89a..724d0ff5 100644
--- a/recipes-fsl/packagegroups/packagegroup-fsl-opencv-imx.bb
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-opencv-imx.bb
@@ -7,6 +7,6 @@ OPENCV_PKGS = " \
opencv-samples \
python3-opencv \
"
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
${OPENCV_PKGS} \
"
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-qca6174.bb b/recipes-fsl/packagegroups/packagegroup-fsl-qca6174.bb
deleted file mode 100644
index aeba7623..00000000
--- a/recipes-fsl/packagegroups/packagegroup-fsl-qca6174.bb
+++ /dev/null
@@ -1,13 +0,0 @@
-# Copyright 2019 NXP
-
-SUMMARY = "Qualcomm Wi-Fi support"
-
-inherit packagegroup
-
-RDEPENDS_${PN} = " \
- kernel-module-qca6174 \
- firmware-qca6174 \
-"
-
-COMPATIBLE_HOST = '(aarch64|arm).*-linux'
-COMPATIBLE_HOST_libc-musl = 'null'
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-qca9377.bb b/recipes-fsl/packagegroups/packagegroup-fsl-qca9377.bb
deleted file mode 100644
index 43df5a70..00000000
--- a/recipes-fsl/packagegroups/packagegroup-fsl-qca9377.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-# Copyright 2019 NXP
-
-SUMMARY = "Qualcomm Wi-Fi support"
-
-inherit packagegroup
-
-RDEPENDS_${PN} = " \
- kernel-module-qca9377 \
- firmware-qca9377 \
-"
-COMPATIBLE_HOST = '(aarch64|arm).*-linux'
-COMPATIBLE_HOST_libc-musl = 'null'