aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb')
-rw-r--r--recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
new file mode 100644
index 00000000..50885ee1
--- /dev/null
+++ b/recipes-fsl/packagegroups/packagegroup-fsl-mfgtool.bb
@@ -0,0 +1,47 @@
+# Copyright (C) 2014 O.S. Systems Software LTDA.
+
+SUMMARY = "Freescale Manufacturing Tool requirements"
+LICENSE = "MIT"
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
+inherit packagegroup
+
+PACKAGES = " \
+ ${PN}-base \
+ ${PN}-mtd \
+ ${PN}-extfs \
+"
+
+# The essential packages for device bootup that may be set in the
+# machine configuration file.
+MACHINE_ESSENTIAL_EXTRA_RDEPENDS ?= ""
+
+# Distro can override the following VIRTUAL-RUNTIME providers:
+VIRTUAL-RUNTIME_keymaps ?= "keymaps"
+
+RDEPENDS_${PN}-base = " \
+ bash \
+ imx-uuc \
+ util-linux \
+ coreutils \
+ dosfstools \
+ mmc-utils \
+ base-files \
+ base-passwd \
+ busybox \
+ ${@base_contains("MACHINE_FEATURES", "keyboard", "${VIRTUAL-RUNTIME_keymaps}", "", d)} \
+ ${MACHINE_ESSENTIAL_EXTRA_RDEPENDS} \
+"
+
+RDEPENDS_${PN}-mtd = " \
+ ${PN}-base \
+ imx-kobs \
+ mtd-utils \
+ mtd-utils-ubifs \
+"
+
+RDEPENDS_${PN}-extfs = " \
+ ${PN}-base \
+ e2fsprogs-mke2fs \
+"