aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-extended/odp/odp_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-extended/odp/odp_git.bb')
-rw-r--r--recipes-extended/odp/odp_git.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/recipes-extended/odp/odp_git.bb b/recipes-extended/odp/odp_git.bb
index b7c7deb6..b9d45581 100644
--- a/recipes-extended/odp/odp_git.bb
+++ b/recipes-extended/odp/odp_git.bb
@@ -12,8 +12,6 @@ ODP_SOC ?= ""
ODP_SOC_ls1043ardb = "LS1043"
ODP_SOC_ls1046ardb = "LS1046"
ODP_PLATFORM ?= "linux-dpaa2"
-ODP_PLATFORM_ls1043ardb = "linux-dpaa1"
-ODP_PLATFORM_ls1046ardb = "linux-dpaa1"
ODP_BUILD_TYPE ?= "ls2088"
ODP_BUILD_TYPE_ls1043ardb = "ls1043"
ODP_BUILD_TYPE_ls1046ardb = "ls1046"
@@ -21,8 +19,6 @@ ODP_BUILD_TYPE_ls2080ardb = "ls2080"
ODP_BUILD_TYPE_ls1088ardb = "ls1088"
EXTRA_OECONF = "--with-platform=${ODP_PLATFORM} \
- --with-sdk-install-path=${STAGING_DIR_TARGET} \
- --enable-build-type=${ODP_BUILD_TYPE} \
--enable-test-vald \
--enable-test-perf \
--enable-test-cpp \
@@ -32,6 +28,8 @@ EXTRA_OEMAKE = "CROSS_COMPILE="${TARGET_PREFIX}" \
SYSROOT="${STAGING_DIR_TARGET}" \
"
+CFLAGS += "-Wno-format-truncation -Wno-maybe-uninitialized -Wno-implicit-fallthrough"
+
PACKAGECONFIG[perf] = "--enable-test-perf,,,"
do_configure_prepend () {