aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r--recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb b/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb
new file mode 100644
index 00000000..a24604df
--- /dev/null
+++ b/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "AIOP Tool is a userspace application for performing operations \
+on an AIOP Tile using MC interfaces. This application enables the user to \
+fetch status of tile, load a valid ELF file and run it on a tile and get and set \
+time of day."
+SECTION = "dpaa2"
+LICENSE = "Freescale-EULA"
+LIC_FILES_CHKSUM = "file://Freescale-EULA;md5=395c11b7d81446eaa8f997521afe0ebb"
+
+SRC_URI = "git://git.freescale.com/ppc/sdk/gpp-aioptool.git;nobranch=1 \
+"
+SRCREV = "d2b674e0a084429c89994dc8b39827592917a7a6"
+
+S = "${WORKDIR}/git"
+
+TARGET_CC_ARCH += "${LDFLAGS}"
+
+EXTRA_OEMAKE = 'KERNEL_PATH="${STAGING_KERNEL_DIR}"'
+
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
+
+do_install () {
+ oe_runmake install DESTDIR=${D}
+}
+
+COMPATIBLE_MACHINE = "(ls2088a)"