aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa2')
-rw-r--r--recipes-dpaa2/aiopsl/aiopsl_git.bb19
-rw-r--r--recipes-dpaa2/dce/dce_git.bb13
-rw-r--r--recipes-dpaa2/dce/files/0001-support-user-merge.patch31
-rw-r--r--recipes-dpaa2/dpl-examples/dpl-examples_git.bb35
-rw-r--r--recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-add-fcommon-to-fix-gcc-10-build-issue.patch36
-rw-r--r--recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-remove-libio.h.patch1
-rw-r--r--recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb4
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.37.0.bb (renamed from recipes-dpaa2/management-complex/management-complex_10.14.3.bb)20
-rw-r--r--recipes-dpaa2/restool/files/disable-manpage-generation.patch26
-rw-r--r--recipes-dpaa2/restool/restool/0001-restool-fix-build-error-with-gcc7.patch24
-rw-r--r--recipes-dpaa2/restool/restool_git.bb21
-rw-r--r--recipes-dpaa2/spc/spc_git.bb8
12 files changed, 140 insertions, 98 deletions
diff --git a/recipes-dpaa2/aiopsl/aiopsl_git.bb b/recipes-dpaa2/aiopsl/aiopsl_git.bb
index feff783a..68f7a8de 100644
--- a/recipes-dpaa2/aiopsl/aiopsl_git.bb
+++ b/recipes-dpaa2/aiopsl/aiopsl_git.bb
@@ -7,26 +7,25 @@ BASEDEPENDS = ""
S = "${WORKDIR}/git"
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/aiopsl;nobranch=1"
+SRC_URI = "git://github.com/nxp-qoriq/aiopsl;protocol=https;nobranch=1"
SRCREV = "87d83d8e99770325cc7ad9e10965c9959e7cb828"
do_configure[noexec] = "1"
do_compile[noexec] = "1"
-DEMOS_PATH_ls2088a = "LS2088A"
-DEMOS_PATH_ls1088a = "LS1088A"
+DEMOS_PATH:ls2088a = "LS2088A"
+DEMOS_PATH:ls1088a = "LS1088A"
do_install () {
install -d ${D}/usr/aiop/bin
- install -d ${D}/usr/aiop/scripts
- install -d ${D}/usr/aiop/traffic_files
- install -m 755 ${S}/demos/images/${DEMOS_PATH}/*.elf ${D}/usr/aiop/bin
- install -m 755 ${S}/misc/setup/scripts/dynamic_aiop_*.sh ${D}/usr/aiop/scripts
- install -m 644 ${S}/misc/setup/traffic_files/classifier.pcap ${D}/usr/aiop/traffic_files
+ install -d ${D}/usr/aiop/
+ cp -rf ${S}/demos/images/* ${D}/usr/aiop/bin
+ cp -rf ${S}/misc/setup/scripts ${D}/usr/aiop/
+ cp -rf ${S}/misc/setup/traffic_files/ ${D}/usr/aiop/
}
-FILES_${PN} += "/usr/aiop/*"
-INSANE_SKIP_${PN} += "arch"
+FILES:${PN} += "/usr/aiop/*"
+INSANE_SKIP:${PN} += "arch"
INHIBIT_PACKAGE_STRIP = "1"
INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
COMPATIBLE_MACHINE = "(ls2088a|ls1088a)"
diff --git a/recipes-dpaa2/dce/dce_git.bb b/recipes-dpaa2/dce/dce_git.bb
index 2e0b4537..7c0ec270 100644
--- a/recipes-dpaa2/dce/dce_git.bb
+++ b/recipes-dpaa2/dce/dce_git.bb
@@ -3,11 +3,14 @@ SECTION = "dpaa2"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=956df5ea6cfe0a1dcf2dee7ca37c0cdf"
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/dce;nobranch=1 \
- git://source.codeaurora.org/external/qoriq/qoriq-components/qbman_userspace;nobranch=1;name=qbman;destsuffix=git/lib/qbman_userspace \
+SRC_URI = "git://github.com/nxp-qoriq/dce;protocol=https;nobranch=1 \
+ git://github.com/nxp-qoriq/qbman_userspace;protocol=https;nobranch=1;name=qbman;destsuffix=git/lib/qbman_userspace \
+ file://0001-support-user-merge.patch \
"
-SRCREV = "0455555e5ce6f469d0c60e25f14a2340054a531a"
-SRCREV_qbman = "a1af1e1528fe2e1ce0df1e6d9170b6c239c8ab4f"
+SRCREV = "9db9c08379aa89f45f514f4f3f0a8e8212198758"
+SRCREV_qbman = "2f92993a9f34e5221d6b36c63b9e30ef703e9ac3"
+
+SRCREV_FORMAT = "default_qbman"
S = "${WORKDIR}/git"
@@ -17,5 +20,5 @@ do_install () {
oe_runmake install DESTDIR=${D}
}
-INSANE_SKIP_${PN} = "ldflags"
+INSANE_SKIP:${PN} = "ldflags"
COMPATIBLE_MACHINE = "(qoriq-arm64)"
diff --git a/recipes-dpaa2/dce/files/0001-support-user-merge.patch b/recipes-dpaa2/dce/files/0001-support-user-merge.patch
new file mode 100644
index 00000000..33b351a1
--- /dev/null
+++ b/recipes-dpaa2/dce/files/0001-support-user-merge.patch
@@ -0,0 +1,31 @@
+From d4aa7f64db5841242257c5b30dd652afd0f6ff68 Mon Sep 17 00:00:00 2001
+From: Hongxu Jia <hongxu.jia@windriver.com>
+Date: Wed, 20 Oct 2021 14:00:35 +0800
+Subject: [PATCH] support user merge
+
+Use Yocto base_sbindir to replace hardcode ./sbin
+
+Upstream-Status: Inappropriate [oe specific]
+
+Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
+---
+ Makefile | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index 62eff25..18b79b1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -25,7 +25,8 @@ CFLAGS += -fdiagnostics-color
+
+ LDFLAGS = -static -Wl,--hash-style=gnu ${EXTRA_CFLAGS}
+
+-PREFIX = $(DESTDIR)/sbin
++base_sbindir ?= ./sbin
++PREFIX = $(DESTDIR)/${base_sbindir}
+
+ HEADER_DEPENDENCIES = $(subst .o,.d,$(OBJS))
+
+--
+2.27.0
+
diff --git a/recipes-dpaa2/dpl-examples/dpl-examples_git.bb b/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
deleted file mode 100644
index aca35a84..00000000
--- a/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
+++ /dev/null
@@ -1,35 +0,0 @@
-SUMMARY = "Datapath layout examples"
-LICENSE = "Freescale-EULA"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987"
-
-DEPENDS = "dtc-native"
-
-inherit deploy fsl-eula-unpack
-
-SRC_URI = "git://github.com/qoriq-open-source/dpl-examples.git;fsl-eula=true;nobranch=1"
-SRCREV = "a6c83759c0d9c02822eec89e86357a0998ef51d4"
-
-S = "${WORKDIR}/git"
-
-REGLEX_ls2088a = "ls2088a"
-REGLEX_ls1088a = "ls1088a"
-
-do_install () {
- install -d ${D}/boot
- install -m 644 ${S}/${REGLEX}/RDB/*.dtb ${D}/boot
- install -m 644 ${S}/${REGLEX}/RDB/custom/*.dtb ${D}/boot
-}
-
-do_deploy () {
- install -d ${DEPLOYDIR}/dpl-examples
- install -m 644 ${S}/${REGLEX}/RDB/*.dtb ${DEPLOYDIR}/dpl-examples
- install -m 644 ${S}/${REGLEX}/RDB/custom/*.dtb ${DEPLOYDIR}/dpl-examples
-}
-addtask deploy before do_build after do_install
-
-PACKAGES += "${PN}-image"
-FILES_${PN}-image += "/boot"
-
-COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a|ls1088a)"
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
diff --git a/recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-add-fcommon-to-fix-gcc-10-build-issue.patch b/recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-add-fcommon-to-fix-gcc-10-build-issue.patch
new file mode 100644
index 00000000..6b69e7fd
--- /dev/null
+++ b/recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-add-fcommon-to-fix-gcc-10-build-issue.patch
@@ -0,0 +1,36 @@
+From e506c4ea7e576e713fa64569b6784bdc22b3205f Mon Sep 17 00:00:00 2001
+From: Ting Liu <ting.liu@nxp.com>
+Date: Fri, 9 Oct 2020 13:13:13 +0530
+Subject: [PATCH] add -fcommon to fix gcc 10 build issue
+
+Fix:
+| ...ld: src/aiop_logger.o:(.bss+0x0): multiple definition of `_debug_flag'; src/aiop_tool.o:(.bss+0x0): first defined here
+| ...ld: src/aiop_logger.o:(.bss+0x2): multiple definition of `_verbose_flag'; src/aiop_tool.o:(.bss+0x2): first defined here
+
+Reference: https://gcc.gnu.org/gcc-10/porting_to.html
+As a workaround, legacy C code where all tentative definitions should be
+placed into a common block can be compiled with -fcommon.
+
+Upstream-Status: Pending
+
+Signed-off-by: Ting Liu <ting.liu@nxp.com>
+---
+ Makefile | 2 +-
+ 1 files changed, 1 insertion(+), 1 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index f10dda2..f568788 100644
+--- a/Makefile
++++ b/Makefile
+@@ -23,7 +23,7 @@ BINDIR = bin
+
+
+ # FLAGS
+-CFLAGS = -Wall
++CFLAGS = -Wall -fcommon
+ #CFLAGS += -g -O0 # Enable for Debugging
+ CFLAGS += -I$(top_builddir)/include
+ CFLAGS += -I$(top_builddir)/src
+--
+2.17.1
+
diff --git a/recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-remove-libio.h.patch b/recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-remove-libio.h.patch
index 92b75f76..d8bc30b4 100644
--- a/recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-remove-libio.h.patch
+++ b/recipes-dpaa2/gpp-aioptool/gpp-aioptool/0001-remove-libio.h.patch
@@ -5,6 +5,7 @@ Subject: [PATCH] remove libio.h
update for glibc libio.h removal in 2.28+
+Upstream-Status: Pending
Signed-off-by: BJ DevOps Team <bjdevops@NXP1.onmicrosoft.com>
---
flib/mc/fsl_mc_sys.h | 1 -
diff --git a/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb b/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb
index a9c3180f..303aa8ff 100644
--- a/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb
+++ b/recipes-dpaa2/gpp-aioptool/gpp-aioptool_git.bb
@@ -6,8 +6,9 @@ SECTION = "dpaa2"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987"
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/gpp-aioptool;nobranch=1 \
+SRC_URI = "git://github.com/nxp-qoriq/gpp-aioptool;protocol=https;nobranch=1 \
file://0001-remove-libio.h.patch \
+ file://0001-add-fcommon-to-fix-gcc-10-build-issue.patch \
"
SRCREV = "6ead470dde043f3ca67f1ba19b313dd64ec199e1"
@@ -21,6 +22,7 @@ do_configure[depends] += "virtual/kernel:do_shared_workdir"
do_install () {
oe_runmake install DESTDIR=${D}
+ chown -R root:root ${D}${bindir}/aiop_tool
}
COMPATIBLE_MACHINE = "(ls2088a|ls1088a)"
diff --git a/recipes-dpaa2/management-complex/management-complex_10.14.3.bb b/recipes-dpaa2/management-complex/management-complex_10.37.0.bb
index b77c4fb3..d1877159 100644
--- a/recipes-dpaa2/management-complex/management-complex_10.14.3.bb
+++ b/recipes-dpaa2/management-complex/management-complex_10.37.0.bb
@@ -1,19 +1,20 @@
SUMMARY = "DPAA2 Management Complex Firmware"
LICENSE = "NXP-Binary-EULA"
-LIC_FILES_CHKSUM = "file://NXP-Binary-EULA.txt;md5=afcb1213054384820390d410ab62105f"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=481d6288552113961a835bbabceb0c33"
-inherit deploy fsl-eula-unpack
+inherit deploy
INHIBIT_DEFAULT_DEPS = "1"
-SRC_URI = "git://github.com/nxp/qoriq-mc-binary;fsl-eula=true;nobranch=1"
-SRCREV = "bd64d1824681b009fd83b0a3699e45b117b72695"
+SRC_URI = "git://github.com/nxp/qoriq-mc-binary;protocol=https;nobranch=1"
+SRCREV = "bb19f586b87b97878b4bd0d3e57da2ca40c5c69f"
S = "${WORKDIR}/git"
-REGLEX_ls2088a = "ls2088a"
-REGLEX_ls1088a = "ls1088a"
-REGLEX_lx2160a = "lx2160a"
+REGLEX:ls2088a = "ls2088a"
+REGLEX:ls1088a = "ls1088a"
+REGLEX:lx2160a = "lx216xa"
+REGLEX:lx2162a = "lx216xa"
do_install () {
install -d ${D}/boot
@@ -24,17 +25,16 @@ do_deploy () {
install -d ${DEPLOYDIR}/mc_app
install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
# make a symlink to the latest binary
- for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do
+ for mc_binary in `find ${DEPLOYDIR}/mc_app -type f -printf "%f\n" |sort`;do
ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
done
}
addtask deploy before do_build after do_install
PACKAGES += "${PN}-image"
-FILES_${PN}-image += "/boot"
+FILES:${PN}-image += "/boot"
INHIBIT_PACKAGE_STRIP = "1"
COMPATIBLE_MACHINE = "(qoriq-arm64)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-
diff --git a/recipes-dpaa2/restool/files/disable-manpage-generation.patch b/recipes-dpaa2/restool/files/disable-manpage-generation.patch
new file mode 100644
index 00000000..34f2ae2d
--- /dev/null
+++ b/recipes-dpaa2/restool/files/disable-manpage-generation.patch
@@ -0,0 +1,26 @@
+From 5392152e704ff001c41de03445d668227237a87e Mon Sep 17 00:00:00 2001
+From: Ting Liu <ting.liu@nxp.com>
+Date: Fri, 15 Oct 2021 09:36:04 +0530
+Subject: [PATCH] disable manpage generation
+
+Upstream-Status: Inappropriate [Cross-compile specific]
+Signed-off-by: Ting Liu <ting.liu@nxp.com>
+---
+ Makefile | 1 -
+ 1 file changed, 1 deletion(-)
+
+diff --git a/Makefile b/Makefile
+index ee669ae..ab6e499 100644
+--- a/Makefile
++++ b/Makefile
+@@ -60,7 +60,6 @@ install: restool scripts/ls-main scripts/ls-append-dpl scripts/ls-debug scripts/
+ install -D -m 755 scripts/ls-debug $(DESTDIR)$(bindir)/ls-debug
+ $(foreach symlink, $(RESTOOL_SCRIPT_SYMLINKS), sh -c "cd $(DESTDIR)$(bindir) && ln -sf ls-main $(symlink)" ;)
+ install -D -m 755 scripts/restool_completion.sh $(DESTDIR)$(bindir_completion)/restool
+- install -m 0644 -D $(MANPAGE) $(call get_manpage_destination,$(MANPAGE))
+
+ clean:
+ rm -f $(OBJ) $(MANPAGE) \
+--
+2.25.1
+
diff --git a/recipes-dpaa2/restool/restool/0001-restool-fix-build-error-with-gcc7.patch b/recipes-dpaa2/restool/restool/0001-restool-fix-build-error-with-gcc7.patch
deleted file mode 100644
index 82ade02b..00000000
--- a/recipes-dpaa2/restool/restool/0001-restool-fix-build-error-with-gcc7.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 895db76654c796a0edc6b2d329addde108b1755c Mon Sep 17 00:00:00 2001
-From: Chunrong Guo <chunrong.guo@nxp.com>
-Date: Wed, 19 Jul 2017 14:31:23 +0800
-Subject: [PATCH] restool: fix build error with gcc7
-
----
- Makefile | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/Makefile b/Makefile
-index 3976b66..df1e791 100644
---- a/Makefile
-+++ b/Makefile
-@@ -64,7 +64,6 @@ CFLAGS = ${EXTRA_CFLAGS} \
- -Wmissing-prototypes \
- -Wpointer-arith \
- -Winline \
-- -Werror \
- -Wundef \
- -Icommon/
-
---
-2.7.4
-
diff --git a/recipes-dpaa2/restool/restool_git.bb b/recipes-dpaa2/restool/restool_git.bb
index 521aa7ad..1d1aeffe 100644
--- a/recipes-dpaa2/restool/restool_git.bb
+++ b/recipes-dpaa2/restool/restool_git.bb
@@ -1,17 +1,17 @@
SUMMARY = "DPAA2 Resource Manager Tool"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://COPYING;md5=ec8d84e9cd4de287e290275d09db27f0"
+LICENSE = "BSD-3-Clause | GPL-2.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ec8d84e9cd4de287e290275d09db27f0"
-RDEPENDS_${PN} += "bash dtc"
-
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/restool;nobranch=1 \
- file://0001-restool-fix-build-error-with-gcc7.patch"
-
-SRCREV = "8b1dd407bbd48b4f1a50c71b78083112a6397619"
+SRC_URI = "git://github.com/nxp-qoriq/restool;protocol=https;nobranch=1 \
+ file://disable-manpage-generation.patch \
+"
+SRCREV = "46604e41f4c7e54efa62503c6b4629321b21e056"
S = "${WORKDIR}/git"
-EXTRA_OEMAKE = 'CC="${CC}" EXTRA_CFLAGS="-Wno-missing-field-initializers -Wno-missing-braces"'
+inherit bash-completion
+
+EXTRA_OEMAKE = 'CC="${CC}" MANPAGE= EXTRA_CFLAGS="-O2 -Wno-missing-field-initializers -Wno-missing-braces -Wno-maybe-uninitialized -Wno-date-time"'
do_install () {
oe_runmake install DESTDIR=${D}
@@ -20,3 +20,6 @@ do_install () {
COMPATIBLE_MACHINE = "(qoriq-arm64)"
PACKAGE_ARCH = "${MACHINE_ARCH}"
+RDEPENDS:${PN} += "bash dtc"
+RDEPENDS:${PN}-bash-completion += "bash"
+
diff --git a/recipes-dpaa2/spc/spc_git.bb b/recipes-dpaa2/spc/spc_git.bb
index eceabf91..2c695368 100644
--- a/recipes-dpaa2/spc/spc_git.bb
+++ b/recipes-dpaa2/spc/spc_git.bb
@@ -1,18 +1,18 @@
SUMMARY = "Soft Parser Configuration tool"
LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://COPYING;md5=163b09a1c249a6ff2b28da1ceca2e0a8"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=163b09a1c249a6ff2b28da1ceca2e0a8"
DEPENDS = "libxml2 fmlib tclap"
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/spc;nobranch=1"
-SRCREV = "1a414247ad3228bf60bfb53995a28930a8a29acc"
+SRC_URI = "git://github.com/nxp-qoriq/spc;protocol=https;nobranch=1"
+SRCREV = "d624b7809be48e4cf29a7bfa201028e4de1d1955"
S = "${WORKDIR}/git"
EXTRA_OEMAKE = 'FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \
FMD_USPACE_LIB_PATH="${STAGING_LIBDIR}" LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2" \
TCLAP_HEADER_PATH="${STAGING_INCDIR}" '
-EXTRA_OEMAKE_virtclass-native = 'FMCHOSTMODE=1 FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \
+EXTRA_OEMAKE:class-native = 'FMCHOSTMODE=1 FMD_USPACE_HEADER_PATH="${STAGING_INCDIR}/fmd" \
FMD_USPACE_LIB_PATH="${STAGING_LIBDIR}" LIBXML2_HEADER_PATH="${STAGING_INCDIR}/libxml2" \
TCLAP_HEADER_PATH="${STAGING_INCDIR}" '