aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2/management-complex
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa2/management-complex')
-rw-r--r--recipes-dpaa2/management-complex/management-complex_10.2.2.bb (renamed from recipes-dpaa2/management-complex/management-complex_10.1.2.bb)13
1 files changed, 8 insertions, 5 deletions
diff --git a/recipes-dpaa2/management-complex/management-complex_10.1.2.bb b/recipes-dpaa2/management-complex/management-complex_10.2.2.bb
index e5fe33b9..a6377547 100644
--- a/recipes-dpaa2/management-complex/management-complex_10.1.2.bb
+++ b/recipes-dpaa2/management-complex/management-complex_10.2.2.bb
@@ -6,19 +6,22 @@ inherit deploy
INHIBIT_DEFAULT_DEPS = "1"
-SRC_URI = "git://git.freescale.com/ppc/sdk/mc-binary.git;nobranch=1"
-SRCREV = "10db0dfa51c8aa6308d7986355bb8b1a3a34d298"
+SRC_URI = "git://github.com/qoriq-open-source/mc-binary.git;nobranch=1"
+SRCREV = "5798f9c2ec0f3b1f2a7a67dc666c87ae3ade837b"
S = "${WORKDIR}/git"
+REGLEX_ls2088a = "ls2088a"
+REGLEX_ls1088a = "ls1088a"
+
do_install () {
install -d ${D}/boot
- install -m 755 ${S}/ls2080a/*.itb ${D}/boot
+ install -m 755 ${S}/${REGLEX}/*.itb ${D}/boot
}
do_deploy () {
install -d ${DEPLOYDIR}/mc_app
- install -m 755 ${S}/ls2080a/*.itb ${DEPLOYDIR}/mc_app
+ install -m 755 ${S}/${REGLEX}/*.itb ${DEPLOYDIR}/mc_app
# make a symlink to the latest binary
for mc_binary in `ls ${DEPLOYDIR}/mc_app |sort`;do
ln -sfT ${mc_binary} ${DEPLOYDIR}/mc_app/mc.itb
@@ -31,6 +34,6 @@ FILES_${PN}-image += "/boot"
INHIBIT_PACKAGE_STRIP = "1"
-COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a)"
+COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a|ls1088a)"
PACKAGE_ARCH = "${MACHINE_ARCH}"