aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-dpaa2/dpl-examples/dpl-examples_git.bb')
-rw-r--r--recipes-dpaa2/dpl-examples/dpl-examples_git.bb15
1 files changed, 9 insertions, 6 deletions
diff --git a/recipes-dpaa2/dpl-examples/dpl-examples_git.bb b/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
index 17946b3f..d6d668ba 100644
--- a/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
+++ b/recipes-dpaa2/dpl-examples/dpl-examples_git.bb
@@ -1,30 +1,33 @@
SUMMARY = "Datapath layout examples"
LICENSE = "Freescale-EULA"
-LIC_FILES_CHKSUM = "file://EULA;md5=c9ae442cf1f9dd6c13dfad64b0ffe73f"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=386a6287daa6504b7e7e5014ddfb3987"
DEPENDS = "dtc-native"
inherit deploy
-SRC_URI = "git://git.freescale.com/ppc/sdk/dpl-examples.git;nobranch=1"
-SRCREV = "cea280fd06b9c43fa73f3d9ef629b171cccd0fcd"
+SRC_URI = "git://github.com/qoriq-open-source/dpl-examples.git;nobranch=1"
+SRCREV = "592fc2fd1f13107c8a4ae8070fed11a5f8d10471"
S = "${WORKDIR}/git"
+REGLEX_ls2088a = "ls2088a"
+REGLEX_ls1088a = "ls1088a"
+
do_install () {
install -d ${D}/boot
- install -m 644 ${S}/ls2080a/RDB/*.dtb ${D}/boot
+ install -m 644 ${S}/${REGLEX}/RDB/*.dtb ${D}/boot
}
do_deploy () {
install -d ${DEPLOYDIR}/dpl-examples
- install -m 644 ${S}/ls2080a/RDB/*.dtb ${DEPLOYDIR}/dpl-examples
+ install -m 644 ${S}/${REGLEX}/RDB/*.dtb ${DEPLOYDIR}/dpl-examples
}
addtask deploy before do_build after do_install
PACKAGES += "${PN}-image"
FILES_${PN}-image += "/boot"
-COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a)"
+COMPATIBLE_MACHINE = "(ls2080ardb|ls2088a|ls1088a)"
PACKAGE_ARCH = "${MACHINE_ARCH}"