aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-devtools')
-rw-r--r--recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch29
-rw-r--r--recipes-devtools/qemu/qemu-qoriq/run-ptest8
-rw-r--r--recipes-devtools/qemu/qemu-qoriq_git.bb8
3 files changed, 45 insertions, 0 deletions
diff --git a/recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch b/recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch
new file mode 100644
index 00000000..a99f7209
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-qoriq/add-ptest-in-makefile.patch
@@ -0,0 +1,29 @@
+Upstream-Status: Pending
+
+Add subpackage -ptest which runs all unit test cases for qemu.
+
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+---
+ tests/Makefile | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/tests/Makefile b/tests/Makefile
+index 88f7105..3f40b4b 100644
+--- a/tests/Makefile
++++ b/tests/Makefile
+@@ -405,3 +405,12 @@ all: $(QEMU_IOTESTS_HELPERS-y)
+
+ -include $(wildcard tests/*.d)
+ -include $(wildcard tests/libqos/*.d)
++
++buildtest-TESTS: $(check-unit-y)
++
++runtest-TESTS:
++ for f in $(check-unit-y); do \
++ nf=$$(echo $$f | sed 's/tests\//\.\//g'); \
++ $$nf; \
++ done
++
+--
+1.7.9.5
+
diff --git a/recipes-devtools/qemu/qemu-qoriq/run-ptest b/recipes-devtools/qemu/qemu-qoriq/run-ptest
new file mode 100644
index 00000000..f4b8e97e
--- /dev/null
+++ b/recipes-devtools/qemu/qemu-qoriq/run-ptest
@@ -0,0 +1,8 @@
+#!/bin/sh
+#
+#This script is used to run qemu test suites
+ptestdir=$(pwd)
+cd tests
+
+export SRC_PATH=$ptestdir
+make -k runtest-TESTS | sed '/: OK/ s/^/PASS: /g'
diff --git a/recipes-devtools/qemu/qemu-qoriq_git.bb b/recipes-devtools/qemu/qemu-qoriq_git.bb
index e799cf2f..26f15967 100644
--- a/recipes-devtools/qemu/qemu-qoriq_git.bb
+++ b/recipes-devtools/qemu/qemu-qoriq_git.bb
@@ -1,3 +1,5 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
require recipes-devtools/qemu/qemu.inc
DESCRIPTION = "This recipe requires poky's qemu.inc which includes the FSL \
@@ -26,6 +28,12 @@ RDEPENDS_${PN}_append = " gnutls"
SRC_URI = "git://git.freescale.com/ppc/sdk/qemu.git;branch=sdk-v1.9.x"
SRCREV = "8362a298c4feef33c84d7db2d111af18bd29ef86"
+# add ptest patches
+SRC_URI_append = "\
+ file://add-ptest-in-makefile.patch \
+ file://run-ptest \
+"
+
S = "${WORKDIR}/git"
QEMU_TARGETS_qoriq-ppc = "ppc"