aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-daemons
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-daemons')
-rw-r--r--recipes-daemons/ptpd/ptpd-qoriq.bb67
-rw-r--r--recipes-daemons/ptpd/ptpd-qoriq/ptpd-use-pkgconfig.patch35
2 files changed, 0 insertions, 102 deletions
diff --git a/recipes-daemons/ptpd/ptpd-qoriq.bb b/recipes-daemons/ptpd/ptpd-qoriq.bb
deleted file mode 100644
index 569deed5..00000000
--- a/recipes-daemons/ptpd/ptpd-qoriq.bb
+++ /dev/null
@@ -1,67 +0,0 @@
-SUMMARY = "The PTP daemon (PTPd)"
-DESCRIPTION = "The PTP daemon (PTPd) implements the Precision Time protocol (PTP) as \
-defined by the relevant IEEE 1588 standard. PTP Version 1 implements IEEE-1588-2002, \
-and PTP Version 2 implements IEEE-1588-2008. PTP was developed to provide very precise \
-time coordination of LAN connected computers."
-HOMEPAGE = "http://sourceforge.net/projects/ptpd"
-SECTION = "net"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://README;md5=0733e1b3788ab2ebbc63bf33a020da1d"
-
-COMPATIBLE_MACHINE = "(qoriq)"
-
-DEPENDS = "libpcap"
-
-PROVIDES = "ptpd"
-
-inherit autotools pkgconfig systemd
-
-python() {
- pkgs = d.getVar('PACKAGES').split()
- for p in pkgs:
- if 'ptpd-qoriq' in p:
- d.appendVar("RPROVIDES_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
- d.appendVar("RCONFLICTS_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
- d.appendVar("RREPLACES_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
-}
-
-# return something like '1.2.3' or '1.2.3/rc1'
-#
-def get_sub(d):
- parts = d.getVar('PV').split('-')
- try:
- return parts[0] + '/' + parts[1]
- except:
- return parts[0]
-
-SRC_URI = "git://source.codeaurora.org/external/qoriq/qoriq-components/ptpd;nobranch=1 \
- file://ptpd-use-pkgconfig.patch \
-"
-SRCREV = "ec34cdd10446619d036ac8d6a86b8276f0d4a81c"
-
-S = "${WORKDIR}/git"
-
-EXTRA_OEMAKE = ""
-
-EXTRA_OECONF += "--disable-snmp --with-pcap-config=pkg-config"
-
-do_install() {
- install -d ${D}${bindir} ${D}${mandir}/man8
- install -m 0755 ${B}/src/ptpd2 ${D}${bindir}
- install -m 0644 ${B}/src/ptpd2.8 ${D}${mandir}/man8
-
- if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/ptpd.service ${D}${systemd_unitdir}/system
-
- sed -i -e 's#@SYSCONFDIR@#${sysconfdir}#g' ${D}${systemd_unitdir}/system/ptpd.service
- sed -i -e 's#@BINDIR@#${bindir}#g' ${D}${systemd_unitdir}/system/ptpd.service
-
- install -d ${D}${sysconfdir}/default/
- install -m 0644 ${WORKDIR}/ptpd.conf ${D}${sysconfdir}/default/ptpd
- fi
-}
-
-SYSTEMD_PACKAGES = "${PN}"
-SYSTEMD_SERVICE_${PN} = "ptpd.service"
-SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/recipes-daemons/ptpd/ptpd-qoriq/ptpd-use-pkgconfig.patch b/recipes-daemons/ptpd/ptpd-qoriq/ptpd-use-pkgconfig.patch
deleted file mode 100644
index e4578dda..00000000
--- a/recipes-daemons/ptpd/ptpd-qoriq/ptpd-use-pkgconfig.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 4c850b92a1cf8cfa19677c66bcde2edfab1a4490 Mon Sep 17 00:00:00 2001
-From: Joe MacDonald <joe_macdonald@mentor.com>
-Date: Tue, 24 Feb 2015 23:02:14 -0500
-Subject: [PATCH] ptpd: use pkgconfig
-
-Yocto uses pkg-config for libpcap, rather than pcap-config, so use that
-instead as the source for libs and cflags.
-
-Upstream-status: Inappropriate [ embedded specific ]
-
-Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
----
- configure.ac | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index dc9541f..288f547 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -112,10 +112,10 @@ case "$try_pcap" in
- yes)
- case "$PATH_PCAP_CONFIG" in
- /*)
-- PCAP_LIBS=`$PATH_PCAP_CONFIG --libs`
-+ PCAP_LIBS=`$PATH_PCAP_CONFIG --libs libpcap`
- AC_SUBST([PCAP_LIBS])
- # Separate CPPFLAGS and CFLAGS
-- foo=`$PATH_PCAP_CONFIG --cflags`
-+ foo=`$PATH_PCAP_CONFIG --cflags libpcap`
- PCAP_CPPFLAGS=
- PCAP_CFLAGS=
- for i in $foo; do
---
-1.9.1
-