aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-daemons/ptpd/ptpd-qoriq.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-daemons/ptpd/ptpd-qoriq.bb')
-rw-r--r--recipes-daemons/ptpd/ptpd-qoriq.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/recipes-daemons/ptpd/ptpd-qoriq.bb b/recipes-daemons/ptpd/ptpd-qoriq.bb
index df3787b2..f3a7f0ce 100644
--- a/recipes-daemons/ptpd/ptpd-qoriq.bb
+++ b/recipes-daemons/ptpd/ptpd-qoriq.bb
@@ -14,6 +14,15 @@ PROVIDES = "ptpd"
inherit autotools pkgconfig systemd
+python() {
+ pkgs = d.getVar('PACKAGES', True).split()
+ for p in pkgs:
+ if 'ptpd-qoriq' in p:
+ d.appendVar("RPROVIDES_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
+ d.appendVar("RCONFLICTS_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
+ d.appendVar("RREPLACES_%s" % p, p.replace('ptpd-qoriq', 'ptpd'))
+}
+
# return something like '1.2.3' or '1.2.3/rc1'
#
def get_sub(d):