aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-core/udev/udev-rules-qoriq.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-core/udev/udev-rules-qoriq.bb')
-rw-r--r--recipes-core/udev/udev-rules-qoriq.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/recipes-core/udev/udev-rules-qoriq.bb b/recipes-core/udev/udev-rules-qoriq.bb
index c0e897e7..c6827da4 100644
--- a/recipes-core/udev/udev-rules-qoriq.bb
+++ b/recipes-core/udev/udev-rules-qoriq.bb
@@ -6,12 +6,14 @@ SRC_URI = "\
file://71-fsl-dpaa-persistent-networking.rules \
file://72-fsl-dpaa-persistent-networking.rules \
"
-RULE ?= "71-fsl-dpaa-persistent-networking.rules"
+RULE_qoriq-ppc = "71-fsl-dpaa-persistent-networking.rules"
RULE_e6500 = "72-fsl-dpaa-persistent-networking.rules"
RULE_e6500-64b = "72-fsl-dpaa-persistent-networking.rules"
RULE_t1024 = "72-fsl-dpaa-persistent-networking.rules"
RULE_t1023 = "72-fsl-dpaa-persistent-networking.rules"
+S = "${WORKDIR}"
+
do_install () {
install -d ${D}${sysconfdir}/udev/rules.d/
install -m 0644 ${WORKDIR}/${RULE} ${D}${sysconfdir}/udev/rules.d/
@@ -22,4 +24,4 @@ do_install () {
echo "/dev/nbd*" >>${D}${sysconfdir}/udev/mount.blacklist
}
-COMPATIBLE_MACHINE = "(qoriq-arm|qoriq-ppc)"
+COMPATIBLE_MACHINE = "(qoriq-ppc)"