aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch85
-rw-r--r--recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb (renamed from recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb)10
2 files changed, 65 insertions, 30 deletions
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
index e7b23f7e..27731004 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro/0001-Fix-ion.h-header-inclusion-to-be-standard.patch
@@ -1,41 +1,74 @@
-From 872c82e7cbb9a0a0e761e8ac70fc28e19a55b4c3 Mon Sep 17 00:00:00 2001
-From: Gary Bisson <gary.bisson@boundarydevices.com>
-Date: Thu, 12 Jul 2018 11:38:28 +0200
-Subject: [PATCH] Fix ion.h header inclusion to be standard
+From cf67cfecc01538e32cd99e3ca00ff0e6145079ce Mon Sep 17 00:00:00 2001
+From: Yuqing Zhu <carol.zhu@nxp.com>
+Date: Thu, 27 Sep 2018 15:34:11 +0800
+Subject: [PATCH] imx-vpu-hantro: Fix ion.h header inclusion to be standard
NXP "solution" was to manually copy the header to include/linux.
Let's point the Makefile to the proper (mainline) location instead:
https://elixir.bootlin.com/linux/v4.17/source/drivers/staging/android/uapi/ion.h
-Signed-off-by: Gary Bisson <gary.bisson@boundarydevices.com>
+Signed-off-by: Yuqing Zhu <carol.zhu@nxp.com>
---
- Makefile | 2 ++
- decoder_sw/software/linux/dwl/dwl_linux.c | 2 +-
- 2 files changed, 3 insertions(+), 1 deletion(-)
+ Makefile_G1G2 | 3 +++
+ Makefile_H1 | 3 +++
+ decoder_sw/software/linux/dwl/dwl_linux.c | 2 +-
+ h1_encoder/software/linux_reference/ewl/ewl_x280_common.c | 2 +-
+ 4 files changed, 8 insertions(+), 2 deletions(-)
-Index: imx-vpu-hantro-1.7.0/decoder_sw/software/linux/dwl/dwl_linux.c
-===================================================================
---- imx-vpu-hantro-1.7.0.orig/decoder_sw/software/linux/dwl/dwl_linux.c
-+++ imx-vpu-hantro-1.7.0/decoder_sw/software/linux/dwl/dwl_linux.c
+diff --git a/Makefile_G1G2 b/Makefile_G1G2
+index caab40f..29866a4 100755
+--- a/Makefile_G1G2
++++ b/Makefile_G1G2
+@@ -13,6 +13,9 @@ INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc
+ #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver
+ INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
+
++# ION header location
++INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
++
+ CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \
+ -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \
+ -DDEC_X170_OUTPUT_FORMAT=0 -DDEC_X170_TIMEOUT_LENGTH=-1 -DENABLE_HEVC_SUPPORT \
+diff --git a/Makefile_H1 b/Makefile_H1
+index 9ca1aa9..56b4332 100755
+--- a/Makefile_H1
++++ b/Makefile_H1
+@@ -20,6 +20,9 @@ ENV += -DUSE_ION
+ ENV += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
+ ENV += -I$(SDKTARGETSYSROOT)/usr/imx/include
+
++# ION header location
++ENV += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
++
+ LIBENCNAME = libcodec_enc
+ LIBSENC = -L./ -lhantro_h1 -lpthread
+
+diff --git a/decoder_sw/software/linux/dwl/dwl_linux.c b/decoder_sw/software/linux/dwl/dwl_linux.c
+index 0899596..f2e1229 100755
+--- a/decoder_sw/software/linux/dwl/dwl_linux.c
++++ b/decoder_sw/software/linux/dwl/dwl_linux.c
@@ -41,7 +41,7 @@
#include "dwl.h"
#include <linux/hantrodec.h>
#ifdef USE_ION
-#include <linux/ion.h>
+#include <ion.h>
+ #include <linux/dma-buf.h>
+ #include <linux/version.h>
#ifdef ANDROID
- #include <linux/mxc_ion.h>
- #endif
-Index: imx-vpu-hantro-1.7.0/Makefile_G1G2
-===================================================================
---- imx-vpu-hantro-1.7.0.orig/Makefile_G1G2
-+++ imx-vpu-hantro-1.7.0/Makefile_G1G2
-@@ -11,6 +11,8 @@ INCLUDE_HEADERS = -I./decoder_sw -I$(SOU
- INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/memalloc
- #INCLUDE_HEADERS += -I$(SOURCE_ROOT)/linux/ldriver
- INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/include/uapi -I$(LINUX_KERNEL_ROOT)/include
-+# ION header location
-+INCLUDE_HEADERS += -I$(LINUX_KERNEL_ROOT)/drivers/staging/android/uapi
+diff --git a/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c b/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c
+index 620c978..82b4836 100755
+--- a/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c
++++ b/h1_encoder/software/linux_reference/ewl/ewl_x280_common.c
+@@ -49,7 +49,7 @@
- CFLAGS += -DDEC_MODULE_PATH=\"/dev/mxc_hantro\" -DUSE_FAKE_RFC_TABLE -DFIFO_DATATYPE=void* -DNDEBUG -DDOWN_SCALER \
- -DUSE_EXTERNAL_BUFFER -DUSE_FAST_EC -DUSE_VP9_EC -DGET_FREE_BUFFER_NON_BLOCK \
+ #include "linux/hx280enc.h"
+ #ifdef USE_ION
+-#include <linux/ion.h>
++#include <ion.h>
+ #include <linux/dma-buf.h>
+ #include <linux/version.h>
+ #ifdef ANDROID
+--
+1.9.1
+
diff --git a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
index da2ac513..243f1f35 100644
--- a/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.7.0.bb
+++ b/recipes-bsp/imx-vpu-hantro/imx-vpu-hantro_1.8.0.bb
@@ -2,9 +2,10 @@
DESCRIPTION = "i.MX Hantro VPU library"
LICENSE = "Proprietary"
-LIC_FILES_CHKSUM = "file://COPYING;md5=ab61cab9599935bfe9f700405ef00f28"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5ab1a30d0cd181e3408077727ea5a2db"
DEPENDS = "virtual/kernel"
+do_configure[depends] += "virtual/kernel:do_shared_workdir"
PROVIDES = "virtual/imxvpu"
@@ -12,13 +13,14 @@ SRC_URI = " \
${FSL_MIRROR}/${PN}-${PV}.bin;fsl-eula=true \
file://0001-Fix-ion.h-header-inclusion-to-be-standard.patch \
"
-SRC_URI[md5sum] = "9a8ade25333e6ac3f7c345b71f3477a6"
-SRC_URI[sha256sum] = "a3bbf2d8ac00ecae6d48b05cb94d9bdf68085d5bfc54eb176e3bf59670a87ad1"
+SRC_URI[md5sum] = "140796ddd6f1be47cffb7e5e2bfe0fb6"
+SRC_URI[sha256sum] = "c092a5b0f8897bae54154f58e47b6d2de033da01ee231a8cd779a51bbe962606"
inherit fsl-eula-unpack
PARALLEL_MAKE="-j 1"
+PLATFORM_mx8mm = "IMX8MM"
PLATFORM_mx8mq = "IMX8MQ"
do_compile () {
@@ -32,4 +34,4 @@ do_install () {
FILES_${PN} += "/unit_tests"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-COMPATIBLE_MACHINE = "(mx8mq)"
+COMPATIBLE_MACHINE = "(mx8mq|mx8mm)"