aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-atf/imx-atf/0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch29
-rw-r--r--recipes-bsp/imx-atf/imx-atf_1.5.0.bb47
2 files changed, 76 insertions, 0 deletions
diff --git a/recipes-bsp/imx-atf/imx-atf/0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch b/recipes-bsp/imx-atf/imx-atf/0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch
new file mode 100644
index 00000000..be747789
--- /dev/null
+++ b/recipes-bsp/imx-atf/imx-atf/0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch
@@ -0,0 +1,29 @@
+From 4123893a8a4d93362a0a36f72134f75436fee457 Mon Sep 17 00:00:00 2001
+From: Tom Hochstein <tom.hochstein@nxp.com>
+Date: Thu, 18 Oct 2018 18:03:46 -0500
+Subject: [PATCH] Allow BUILD_STRING to be set in .revision file.
+
+Upstream-Status: Pending
+
+Signed-off-by: Tom Hochstein <tom.hochstein@nxp.com>
+---
+ Makefile | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/Makefile b/Makefile
+index 57c4a90..ec49397 100644
+--- a/Makefile
++++ b/Makefile
+@@ -97,6 +97,9 @@ endif
+
+ # Default build string (git branch and commit)
+ ifeq (${BUILD_STRING},)
++ BUILD_STRING := $(shell cat .revision 2> /dev/null)
++endif
++ifeq (${BUILD_STRING},)
+ BUILD_STRING := $(shell git describe --long --always --dirty --tags 2> /dev/null)
+ endif
+ VERSION_STRING := v${VERSION_MAJOR}.${VERSION_MINOR}(${BUILD_TYPE}):${BUILD_STRING}
+--
+2.7.4
+
diff --git a/recipes-bsp/imx-atf/imx-atf_1.5.0.bb b/recipes-bsp/imx-atf/imx-atf_1.5.0.bb
new file mode 100644
index 00000000..9d402dba
--- /dev/null
+++ b/recipes-bsp/imx-atf/imx-atf_1.5.0.bb
@@ -0,0 +1,47 @@
+# Copyright 2017-2018 NXP
+
+DESCRIPTION = "i.MX ARM Trusted Firmware"
+SECTION = "BSP"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
+
+PV = "1.5.0+git${SRCPV}"
+
+SRCBRANCH = "imx_4.9.123_imx8mm_ga"
+SRC_URI = "git://source.codeaurora.org/external/imx/imx-atf.git;protocol=https;branch=${SRCBRANCH} \
+ file://0001-Allow-BUILD_STRING-to-be-set-in-.revision-file.patch \
+"
+SRCREV = "af3554fc6ea8c17710ffd37a14a25834fad19271"
+
+S = "${WORKDIR}/git"
+
+inherit deploy
+
+BOOT_TOOLS = "imx-boot-tools"
+
+PLATFORM ?= "INVALID"
+PLATFORM_mx8qm = "imx8qm"
+PLATFORM_mx8qxp = "imx8qxp"
+PLATFORM_mx8mq = "imx8mq"
+PLATFORM_mx8mm = "imx8mm"
+
+EXTRA_OEMAKE += " \
+ CROSS_COMPILE="${TARGET_PREFIX}" \
+ PLAT=${PLATFORM} \
+"
+
+do_compile() {
+ # Clear LDFLAGS to avoid the option -Wl recognize issue
+ unset LDFLAGS
+ oe_runmake bl31
+}
+
+do_install[noexec] = "1"
+
+do_deploy() {
+ install -Dm 0644 ${S}/build/${PLATFORM}/release/bl31.bin ${DEPLOYDIR}/${BOOT_TOOLS}/bl31-${PLATFORM}.bin
+}
+addtask deploy after do_compile
+
+PACKAGE_ARCH = "${MACHINE_SOCARCH}"
+COMPATIBLE_MACHINE = "(mx8)"