aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/inphi/inphi_git.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/recipes-bsp/inphi/inphi_git.bb b/recipes-bsp/inphi/inphi_git.bb
new file mode 100644
index 00000000..c0c8a776
--- /dev/null
+++ b/recipes-bsp/inphi/inphi_git.bb
@@ -0,0 +1,28 @@
+SUMMARY = "Firmwares and Standalone Applications"
+LICENSE = "NXP-Binary-EULA"
+LIC_FILES_CHKSUM = "file://EULA.txt;md5=86d76166990962fa552f840ff08e5798"
+
+inherit deploy fsl-eula-unpack
+
+SRC_URI = "git://github.com/nxp/qoriq-firmware-inphi.git;fsl-eula=true;nobranch=1"
+SRCREV = "f22e9ff3bfed8342da6efb699e473b11fbad5695"
+
+S = "${WORKDIR}/git"
+
+do_install () {
+ install -d ${D}/boot
+ cp -fr ${S}/in112525-phy-ucode.txt ${D}/boot
+}
+
+do_deploy () {
+ install -d ${DEPLOYDIR}/inphi
+ cp -fr ${S}/in112525-phy-ucode.txt ${DEPLOYDIR}/inphi
+}
+addtask deploy before do_build after do_install
+
+PACKAGES += "${PN}-image"
+FILES_${PN}-image += "/boot"
+
+COMPATIBLE_MACHINE = "(qoriq-arm64)"
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+