aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/imx-test/imx-test.inc14
-rw-r--r--recipes-bsp/imx-test/imx-test_5.7.bb8
-rw-r--r--recipes-bsp/imx-test/imx-test_git.bb16
3 files changed, 25 insertions, 13 deletions
diff --git a/recipes-bsp/imx-test/imx-test.inc b/recipes-bsp/imx-test/imx-test.inc
index ce24860d..63eb83d5 100644
--- a/recipes-bsp/imx-test/imx-test.inc
+++ b/recipes-bsp/imx-test/imx-test.inc
@@ -1,23 +1,25 @@
# Copyright (C) 2012-2016 O.S. Systems Software LTDA.
# Copyright (C) 2015 Freescale Semiconductor
+# Copyright 2017 NXP
SUMMARY = "Test programs for IMX BSP"
DESCRIPTION = "Unit tests for the IMX BSP"
SECTION = "base"
-DEPENDS_mx6q = "virtual/kernel imx-lib imx-vpu"
-DEPENDS_mx6dl = "virtual/kernel imx-lib imx-vpu"
+
+DEPENDS_mx6q = "virtual/kernel imx-lib virtual/imxvpu"
+DEPENDS_mx6dl = "virtual/kernel imx-lib virtual/imxvpu"
DEPENDS_mx6sl = "virtual/kernel imx-lib"
+DEPENDS_mx6sll = "virtual/kernel imx-lib"
DEPENDS_mx6sx = "virtual/kernel imx-lib"
DEPENDS_mx6ul = "virtual/kernel imx-lib"
DEPENDS_mx7d = "virtual/kernel imx-lib"
+DEPENDS_mx7ulp = "virtual/kernel imx-lib"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
PE = "1"
-SRC_URI = "${FSL_MIRROR}/imx-test-${PV}.tar.gz"
-
inherit module-base
INHIBIT_PACKAGE_STRIP = "1"
@@ -26,9 +28,11 @@ INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
PLATFORM_mx6q = "IMX6Q"
PLATFORM_mx6dl = "IMX6Q"
PLATFORM_mx6sl = "IMX6SL"
+PLATFORM_mx6sll = "IMX6SL"
PLATFORM_mx6sx = "IMX6SX"
-PLATFORM_mx7d = "IMX7D"
PLATFORM_mx6ul = "IMX6UL"
+PLATFORM_mx7d = "IMX7D"
+PLATFORM_mx7ulp = "IMX7D"
PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', '', d)}"
PACKAGECONFIG[x11] = ",,libx11 libxdamage libxrender libxrandr"
diff --git a/recipes-bsp/imx-test/imx-test_5.7.bb b/recipes-bsp/imx-test/imx-test_5.7.bb
deleted file mode 100644
index 766598fb..00000000
--- a/recipes-bsp/imx-test/imx-test_5.7.bb
+++ /dev/null
@@ -1,8 +0,0 @@
-# Copyright (C) 2013-2016 Freescale Semiconductor
-
-include imx-test.inc
-
-SRC_URI[md5sum] = "bf55f7c2c9fd6664d640557f7cd107a1"
-SRC_URI[sha256sum] = "d7a503112098befc91c4d256d8683ca11eb4246123f4e57cf2df498791294888"
-
-COMPATIBLE_MACHINE = "(mx6|mx7)"
diff --git a/recipes-bsp/imx-test/imx-test_git.bb b/recipes-bsp/imx-test/imx-test_git.bb
new file mode 100644
index 00000000..4a2472b3
--- /dev/null
+++ b/recipes-bsp/imx-test/imx-test_git.bb
@@ -0,0 +1,16 @@
+# Copyright (C) 2013-2016 Freescale Semiconductor
+# Copyright 2017 NXP
+
+include imx-test.inc
+
+PV = "6.0+${SRCPV}"
+
+PARALLEL_MAKE="-j 1"
+
+SRCBRANCH = "imx_4.9.11_1.0.0_ga"
+SRC_URI = "git://git.freescale.com/imx/imx-test.git;protocol=git;branch=${SRCBRANCH}"
+SRCREV = "fb250a795ce0d25c19610e9e19e1cd815fc64cb9"
+
+S = "${WORKDIR}/git"
+
+COMPATIBLE_MACHINE = "(mx6|mx7)"