aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/ppa/ppa/0001-fix-path-error.patch79
-rw-r--r--recipes-bsp/ppa/ppa_git.bb6
2 files changed, 83 insertions, 2 deletions
diff --git a/recipes-bsp/ppa/ppa/0001-fix-path-error.patch b/recipes-bsp/ppa/ppa/0001-fix-path-error.patch
new file mode 100644
index 00000000..891a6e75
--- /dev/null
+++ b/recipes-bsp/ppa/ppa/0001-fix-path-error.patch
@@ -0,0 +1,79 @@
+From aa3b419876af9c2a9265fba7c7264130e1bc4926 Mon Sep 17 00:00:00 2001
+From: Chunrong Guo <chunrong.guo@nxp.com>
+Date: Wed, 27 Sep 2017 10:45:04 +0800
+Subject: [PATCH] fix path error
+
+fix the below error:
+|Makefile:58: ../armv8/gic.mk: No such file or directory
+
+Upstream-Status: Submitted
+
+Signed-off-by: Chunrong Guo <chunrong.guo@nxp.com>
+---
+ ppa/soc-ls1046/Makefile | 4 ++--
+ ppa/soc-ls1088/Makefile | 4 ++--
+ ppa/soc-ls2088/Makefile | 5 +++--
+ 3 files changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/ppa/soc-ls1046/Makefile b/ppa/soc-ls1046/Makefile
+index 34ffe2d..6a06514 100644
+--- a/ppa/soc-ls1046/Makefile
++++ b/ppa/soc-ls1046/Makefile
+@@ -55,12 +55,12 @@ include $(PRE_PATH)soc.def
+ # -----------------------------------------------------------------------------
+
+ # include the gic architecture file
+-include ../armv8/gic.mk
++include $(PRE_PATH)../armv8/gic.mk
+
+ # -----------------------------------------------------------------------------
+
+ # include the interconnect architecture file
+-include ../armv8/inter.mk
++include $(PRE_PATH)../armv8/inter.mk
+
+ # -----------------------------------------------------------------------------
+
+diff --git a/ppa/soc-ls1088/Makefile b/ppa/soc-ls1088/Makefile
+index 7fc5db9..6472408 100644
+--- a/ppa/soc-ls1088/Makefile
++++ b/ppa/soc-ls1088/Makefile
+@@ -55,12 +55,12 @@ include $(PRE_PATH)soc.def
+ # -----------------------------------------------------------------------------
+
+ # include the gic architecture file
+-include ../armv8/gic.mk
++include $(PRE_PATH)../armv8/gic.mk
+
+ # -----------------------------------------------------------------------------
+
+ # include the interconnect architecture file
+-include ../armv8/inter.mk
++include $(PRE_PATH)../armv8/inter.mk
+
+ # -----------------------------------------------------------------------------
+
+diff --git a/ppa/soc-ls2088/Makefile b/ppa/soc-ls2088/Makefile
+index de3a06c..2fe23e2 100644
+--- a/ppa/soc-ls2088/Makefile
++++ b/ppa/soc-ls2088/Makefile
+@@ -54,13 +54,14 @@ include $(PRE_PATH)soc.def
+
+ # -----------------------------------------------------------------------------
+
++include $(PRE_PATH)../armv8/gic.mk
+ # include the gic architecture file
+-include ../armv8/gic.mk
++include $(PRE_PATH)../armv8/gic.mk
+
+ # -----------------------------------------------------------------------------
+
+ # include the interconnect architecture file
+-include ../armv8/inter.mk
++include $(PRE_PATH)../armv8/inter.mk
+
+ # -----------------------------------------------------------------------------
+
+--
+2.7.4
+
diff --git a/recipes-bsp/ppa/ppa_git.bb b/recipes-bsp/ppa/ppa_git.bb
index ede3b643..c4f81bc5 100644
--- a/recipes-bsp/ppa/ppa_git.bb
+++ b/recipes-bsp/ppa/ppa_git.bb
@@ -6,8 +6,10 @@ DEPENDS += "u-boot-mkimage-native dtc-native"
inherit deploy
-SRC_URI = "git://github.com/qoriq-open-source/ppa-generic.git;nobranch=1"
-SRCREV = "265d766de8c7f3161f2580af18558af35e114845"
+SRC_URI = "git://github.com/qoriq-open-source/ppa-generic.git;nobranch=1 \
+ file://0001-fix-path-error.patch \
+"
+SRCREV = "92b208b0dbb5a47b06627ec62824cb5790b3f482"
S = "${WORKDIR}/git"