aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc12
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2017.09.bb11
2 files changed, 11 insertions, 12 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc
index f2b4e83a..7bfe3316 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc
@@ -1,20 +1,10 @@
# Copyright (C) 2012-2017 O.S. Systems Software LTDA.
# Released under the MIT license (see COPYING.MIT for the terms)
-require recipes-bsp/u-boot/u-boot.inc
-
inherit fsl-u-boot-localversion
-DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
-order to provide support for some backported features and fixes, or because it \
-was submitted for revision and it takes some time to become part of a stable \
-version, or because it is not applicable for upstreaming."
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
-COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)"
-
-DEPENDS_append = " dtc-native"
-DEPENDS_mxs += "elftosb-native openssl-native"
SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
@@ -24,5 +14,3 @@ SRCBRANCH = "2017.09+fslc"
PV = "v2017.09+git${SRCPV}"
S = "${WORKDIR}/git"
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb b/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb
index 3aff2fa7..5659e16c 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb
@@ -1,5 +1,13 @@
+require recipes-bsp/u-boot/u-boot.inc
require u-boot-fslc-common_${PV}.inc
+DESCRIPTION = "U-Boot based on mainline U-Boot used by FSL Community BSP in \
+order to provide support for some backported features and fixes, or because it \
+was submitted for revision and it takes some time to become part of a stable \
+version, or because it is not applicable for upstreaming."
+
+DEPENDS_append = " dtc-native"
+
PROVIDES += "u-boot"
# FIXME: Allow linking of 'tools' binaries with native libraries
@@ -8,3 +16,6 @@ PROVIDES += "u-boot"
EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
HOSTLDFLAGS="${BUILD_LDFLAGS}" \
HOSTSTRIP=true'
+
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)"