aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb20
1 files changed, 12 insertions, 8 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
index b67a53ce..533bfbf6 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
@@ -3,23 +3,27 @@ require u-boot-fslc-common_${PV}.inc
DESCRIPTION = "U-boot bootloader mxsboot tool"
SECTION = "bootloader"
-DEPENDS_append = " openssl"
+DEPENDS = "openssl"
PROVIDES = "u-boot-mxsboot"
-EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y'
+EXTRA_OEMAKE_class-target = 'CROSS_COMPILE="${TARGET_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
+EXTRA_OEMAKE_class-native = 'CC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
+EXTRA_OEMAKE_class-nativesdk = 'CROSS_COMPILE="${HOST_PREFIX}" CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" STRIP=true V=1 CONFIG_MX28=y'
-do_configure () {
+do_compile () {
oe_runmake sandbox_defconfig
-}
-do_compile () {
- oe_runmake tools-only
+ # Disable CONFIG_CMD_LICENSE, license.h is not used by tools and
+ # generating it requires bin2header tool, which for target build
+ # is built with target tools and thus cannot be executed on host.
+ sed -i "s/CONFIG_CMD_LICENSE=.*/# CONFIG_CMD_LICENSE is not set/" .config
+
+ oe_runmake cross_tools NO_SDL=1
}
do_install () {
- install -d ${D}${bindir}
- install -m 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
+ install -Dm 0755 tools/mxsboot ${D}${bindir}/uboot-mxsboot
ln -sf uboot-mxsboot ${D}${bindir}/mxsboot
}