aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.11.bb6
1 files changed, 2 insertions, 4 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.11.bb b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.11.bb
index 7c2864ed..84ba445b 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.11.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-fw-utils_2017.11.bb
@@ -1,9 +1,7 @@
-require recipes-bsp/u-boot/u-boot.inc
require u-boot-fslc-common_${PV}.inc
SUMMARY = "U-Boot bootloader fw_printenv/setenv utilities"
-
-DEPENDS_append = " mtd-utils"
+DEPENDS = "mtd-utils"
INSANE_SKIP_${PN} = "already-stripped"
EXTRA_OEMAKE_class-target = 'CROSS_COMPILE=${TARGET_PREFIX} CC="${CC} ${CFLAGS} ${LDFLAGS}" HOSTCC="${BUILD_CC} ${BUILD_CFLAGS} ${BUILD_LDFLAGS}" V=1'
@@ -13,7 +11,7 @@ inherit uboot-config
do_compile () {
oe_runmake ${UBOOT_MACHINE}
- oe_runmake env
+ oe_runmake envtools
}
do_install () {