aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'recipes-bsp')
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc (renamed from recipes-bsp/u-boot/u-boot-fslc.inc)16
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb17
-rw-r--r--recipes-bsp/u-boot/u-boot-fslc_2017.09.bb12
3 files changed, 17 insertions, 28 deletions
diff --git a/recipes-bsp/u-boot/u-boot-fslc.inc b/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc
index 39ecc2cd..6173cda0 100644
--- a/recipes-bsp/u-boot/u-boot-fslc.inc
+++ b/recipes-bsp/u-boot/u-boot-fslc-common_2017.09.inc
@@ -1,4 +1,4 @@
-# Copyright (C) 2012-2016 O.S. Systems Software LTDA.
+# Copyright (C) 2012-2017 O.S. Systems Software LTDA.
# Released under the MIT license (see COPYING.MIT for the terms)
require recipes-bsp/u-boot/u-boot.inc
@@ -16,19 +16,13 @@ COMPATIBLE_MACHINE = "(mxs|mx5|mx6|mx7|vf|use-mainline-bsp)"
DEPENDS_append = " dtc-native"
DEPENDS_mxs += "elftosb-native openssl-native"
-PROVIDES += "u-boot"
+SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
-SRCBRANCH ??= "master"
+SRCREV = "9f164a1a01fceb53fc88ad474a5cda70f1c486c2"
+SRCBRANCH = "2017.09+fslc"
-SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
+PV = "v2017.09+git${SRCPV}"
S = "${WORKDIR}/git"
-# FIXME: Allow linking of 'tools' binaries with native libraries
-# used for generating the boot logo and other tools used
-# during the build process.
-EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
- HOSTLDFLAGS="${BUILD_LDFLAGS}" \
- HOSTSTRIP=true'
-
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
index 0bbcd084..b67a53ce 100644
--- a/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc-mxsboot_2017.09.bb
@@ -1,20 +1,11 @@
+require u-boot-fslc-common_${PV}.inc
+
DESCRIPTION = "U-boot bootloader mxsboot tool"
-LICENSE = "GPLv2+"
-LIC_FILES_CHKSUM = "file://Licenses/README;md5=a2c678cfd4a4d97135585cad908541c6"
SECTION = "bootloader"
-DEPENDS = "openssl"
-PROVIDES = "u-boot-mxsboot"
-
-PV = "v2017.09+git${SRCPV}"
-SRCREV = "9f164a1a01fceb53fc88ad474a5cda70f1c486c2"
-SRCBRANCH = "2017.09+fslc"
+DEPENDS_append = " openssl"
-SRC_URI = "git://github.com/Freescale/u-boot-fslc.git;branch=${SRCBRANCH}"
-
-S = "${WORKDIR}/git"
-
-inherit fsl-u-boot-localversion
+PROVIDES = "u-boot-mxsboot"
EXTRA_OEMAKE = 'HOSTCC="${CC} ${CPPFLAGS}" HOSTLDFLAGS="-L${libdir} -L${base_libdir}" HOSTSTRIP=true CONFIG_MX28=y'
diff --git a/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb b/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb
index b3fd47a6..3aff2fa7 100644
--- a/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb
+++ b/recipes-bsp/u-boot/u-boot-fslc_2017.09.bb
@@ -1,6 +1,10 @@
-include u-boot-fslc.inc
+require u-boot-fslc-common_${PV}.inc
-PV = "v2017.09+git${SRCPV}"
+PROVIDES += "u-boot"
-SRCREV = "9f164a1a01fceb53fc88ad474a5cda70f1c486c2"
-SRCBRANCH = "2017.09+fslc"
+# FIXME: Allow linking of 'tools' binaries with native libraries
+# used for generating the boot logo and other tools used
+# during the build process.
+EXTRA_OEMAKE += 'HOSTCC="${BUILD_CC} ${BUILD_CPPFLAGS}" \
+ HOSTLDFLAGS="${BUILD_LDFLAGS}" \
+ HOSTSTRIP=true'